Печать документов шрифтом Брайля при помощи программы winbraille

Дата публикации:24.04.2007
Twitter Facebook Vkontakte

Исходное: компьютер любой (сами понимаете, не менее 32 мегабайт оперативки), Брайлевский принтер. Я всё делаю на читающей машине «Инфа-200» и Брайлевском принтере index everest.

К сожалению, с брайлевскими принтерами серии 4 на 4 дела не имел, потому здесь сказать ничего конкретного не могу.

Принтер обычно подсоединяется к порту lpt, например, lpt1.

С официального сайта программы http://www.indexbraille.com берем дистрибутив. Там, обычно, выложены демоверсии, но они нормально работают, моя вторая версия, по крайней мере, совсем не требует регистрации.

Известно, что третья версия умеет работать с таблицами, а о четвертой знаю лишь то, что она существует и доступна на вышеназванном сайте. Русской версии нет, потому берем английскую и работаем с ней, тем более, что основные сообщения, меню и диалоги программы интуитивно понятны (о чем подробнее ниже).

У меня имеется дистрибутив программы, занимает 166 мегабайт в развернутом виде, если у кого-то будет возможность выложить куда-либо, готов закачать, благо подключение по выделенной линии.

Установка программы

В дистрибутиве программы находим стандартный файл установки Setup.exe и жмем на него. Начинается стандартный процесс установки, где надо согласиться с лицензией, указать папку и программную группу установки, что, чаще всего, сводится к простому периодическому нажатию кнопки next в диалоговом окне программы.

На последнем этапе установки программа предложит установить драйвер принтера из имеющихся в программе. Если в данный момент принтер к компьютеру не подключен, то данный процесс можно отложить, нажав cancel, и установка закончится.

Вернуться к установке принтера можно, выбрав из программной группы index braille, что находится по пути «Главное меню» -- «программы» пункт «instal index braille printer(s)».

Во время установки принтера необходимо выбрать из предложенного списка тип принтера, а далее -- порт, в который он подключен, здесь же возможна настройка этого порта.

Таким образом, программа «Увидит» принтер и, в дальнейшем, при отправке на печать обработанного текста будет посылать его на данный принтер.

Если вы установили несколько Брайлевских принтеров, то при отправке на печать, как и в остальных случаях, будет доступен выбор нужного принтера.

Настройка программы

Итак, программа успешно установлена и необходимо ее настроить под конкретные потребности. Для этого ознакомимся с инструментами работы с текстом и программой, предлагаемыми ей в собственном меню.

Меню file

  1. Open (ctrl+o) – открытие нового документа, стандартное диалоговое окно, позволяет открыть файлы с расширениями: ascii files (txt), html files (*.htm *.html), rich text files (*.rtf), word files (*.doc), winbraille files (*.wbr).
    Последний тип – файлы, созданные в самой программе, уже готовые к печати тексты, ну и, конечно же, есть пункт «all formats», значение которого понятно.
  2. New (ctrl+n) – создание нового файла, открывается пустое окно, как и в любом текстовом редакторе.
  3. Save (ctrl+s) – сохранение изменений в файле.
  4. Save as – сохранение нового файла или копии файла под новым именем.
  5. Close – закрытие открытого файла без закрытия программы, этим переходим на ранее открытый файл, если таковой был.
  6. Emboss print (ctrl +p) – печать файла.
  7. Emboss print preview – позволяет и узнать, сколько страниц будет в Брайлевском варианте, но это побочный эффект, главное же, позволяет напечатать страницу с заданым номером из всего списка.
  8. Exit (alt+f4) – закрывает всю программу.
    При закрытии файла и программы стандартно спросить о необходимости сохранения изменений в закрываемых объектах.

Меню Edit

  1. undo (ctrl+z) – отменить предыдущее действие.
  2. Redo (ctrl+y) – повторить предыдущее действие.
  3. Cut (ctrl+x) – вырезать.
  4. Copy (ctrl+c) – копировать.
  5. Paste (ctrl+v) – вставить.
  6. Select all (ctrl+a) – выделить все.
  7. Delete (del) – удалить.
  8. Find (ctrl+f) – найти.
  9. Replace (ctrl+h) – заменить.

Как видите, здесь нет пункта «Найти далее», что несколько усложняет привычную работу, но к этому можно привыкнуть.

Меню View

  1. 50.
  2. 75.
  3. 100.
  4. 150.
  5. 200
  6. page width (по ширине страницы).
  7. whole page. (страница целиком).
  8. Status bar (Строка состояния).

Ну, здесь все понятно из самих пунктов, как видите, меню небогато, но вполне достаточно для работы.

Меню Text

  1. center text (ctrl+e) – текст по центру.
  2. Left text (ctrl+l) –текст слева.
  3. Right text (ctrl+r) – текст справа.
  4. Page break (ctrl+enter) – разрыв страницы.
  5. Font – шрифт.
    Здесь можно выбрать шрифт, которым текст будет отображаться на экране, никакого отношение к окончательной печати этот шрифт не имеет, а Брайлевский шрифт выбирается в другом месте.

Меню Window

  1. tile.
  2. Cascade
  3. Arrange icons
  4. Close all.

Все это о размещении окон программы, понятно из названий.

Меню Braille

Переходим к самому интересному, именно в этом меню необходимо делать все настройки, потому я его на конец и оставил, на самом деле находится между меню «Текст» и «Окно» (естественно, в английском написании.

  1. translate (ctrl+t) – переводит электронный текст вышеописанных форматов с использованием ранее настроенного шрифта в текст, который может быть отправлен на печать. Уже в оттранслированном тексте необходимо делать форматирование и другую редакторскую работу, этот текст при сохранении и будет в формате *.wbr.
  2. profile. На этом пункте намного подробнее:
    Именно здесь и создаются один или несколько профайлов, в которые и будет занесена информация о формате печатаемого текста, если их несколько, между ними можно производить выбор.

    Это диалоговое окно с несколькими вкладками, рассмотрим каждую:
    Вкладка profile. Как обычно, перемещаемся табом и есть кнопки ok и cancel, о которых впоследствии говорить не буду. Сперва select profile here, где можно выбрать нужный профиль, если он один, то и список из одного элемента default, а далее три кнопки change to – внести изменения, create new – создать новый и delete – удалить имеющийся, как всегда, с подтверждением.
    Вкладка emboss. Здесь список принтеров use embosser и флажок old index embosser, у меня он снят и, по-моему, не нужен.
    Вкладка «Translate». Здесь идем, как всегда, табом и вот что видим: automatic processing, где три варианта, три радиокнопки edit translate text, на котором у меня и стоит, edit source first и complete automatic, значения которых я не знаю, но если на них поставить, ничего хорошего не получится.
    Далее пункт use rule file: russian_c1_v2_cgp.ibk. Это файл шрифта, который используется в момент трансляции текста и именно он и есть тот самый шрифт, которым ведется печать по Брайлю. Про шрифты и работу с ними расскажу чуть ниже.
    Затем пункт rule file details, где вкратце информация о файле шрифта, и последним на вкладке флажок enable capture filter «filter.ini», у меня этот флажок стоит.
    Вкладка «Editor». Первым здесь две радиокнопки «default mode shen viewing a translate show black text» и тоже самое, только вместо «black text» -- «braille». Смысл в том, что на экране либо будет отображаться обычный текст, уже в оттранслированном варианте, либо текст будет состоять из точек, как-будто на экране уже по-Брайлю написано. Естественно, второй вариант для нас неприемлем, потому останавливаемся на первом.
    Далее пункт «maximize all window», редактируемый текст на все окно, флажок у меня отмечен.
    Вкладка «format». На этой вкладке собрано все, что относится к формату страницы. Здесь есть следующие поля и значения, которые стоят у меня, можно, естественно, и свои подбирать. Эту вкладку надо настраивать в тесном «Сотрудничестве» с принтером, оглядываясь на его подобные же настройки и часто просто подбором приходим к оптимальным значениям, отталкиваясь от размера бумаги.

    • «top margin» у меня 1,
    • «left binding margin» -- 6,
    • «outer margin» -- 7,
    • «bottom margin» -- 1,
    • «page size bottom margin» -- 115 «x 11», (там много вариантов, стрелками выбирать можно),
    • «duplexing» у меня «double sitet», хотя можно и «single sitet»,
    • «page size in portrait mode» у меня 0.1, есть также вариант 0.001 inches,
    • «orientation» у меня «portrait», хотя можно и «landscape», ну это, сами понимаете, альбомная и книжная ориентация.

    Вкладку «header» я не очень понял, потому оставил всё, как есть, там, насколько я понял, связано с колонтитулами, ее вы посмотрите, сами зайдя на эту вкладку.

  3. Следующий пункт меню «edit rule file» открывает программу, с помощью которой можно редактировать и компилировать файлы шрифтов. Рассмотрим ее подробнее.

    Имеем пустое окно и меню:

    file с пунктами

    • new rule file (ctrl+n),
    • open rule file (ctrl+o),
    • import 10 braille code,
    • save (ctrl+s),
    • save as,
    • print (ctrl+p),
    • exit,
    значение которых понятны;

    edit с пунктами:

    • undo (ctrl+z),
    • cut (ctrl+x),
    • copy (ctrl+c),
    • paste (ctrl+v),
    • delete (del),
    • select all;

    search с пунктами:

    • find (ctrl+f),
    • find next (f3),
    • replace (ctrl+r);

    rule file с пунктами:

    • compile rule file (ctrl+t),
    • text rule file on the fli,
    • text rule file by converting a text file,
    • convert text file to black text,
    • convert text file to braille,
    • return to rule file;

    и меню font с единственным одноименным пунктом.

    Суть этой программы в том, что у каждого файла шрифта есть файл с таким же названием, но расширением txt. Открыть его можно любым текстовым редактором, но лучше сразу воспользоваться для этого предназначенной программой.

    Этот файл по строению похож на инишные файлы, там тоже все по секциям, и его, естественно, можно редактировать под свои нужды.

    Например, совсем мне не хотелось, чтобы в начале каждого предложения и в именах были знаки большой буквы, так я в соответствующей секции заменил их на пробелы. Теперь в начале каждого предложения стоит по лишнему пробелу. Несколько неэстетично, но практически не заметно и лучше, если бы они были. Там такая же таблица соответствий, как и в таблице символов, например типичная строка: «х=п125».

    В общем, меняем, что надо; компилируем, предварительно, на всякий случай, сохранив оригинал, и смотрим, что получилось.

    Возможно, появится сообщение о синтаксической ошибке при компиляции, тогда смотрим, где мы какую-нибудь точку с запятой упустили и пробуем ещё раз, а затем печатаем какой-нибудь текст.

    Если нас все устроило, то хлопаем в ладоши, если нет, крутим дальше.

  4. Значение пункта «display chartable» для меня не очень понятно, там можно увидеть что-то типа таблицы символов, но ничего изменить нельзя.
  5. И последний пункт меню «manage rule files». Здесь мы можем добавить необходимые нам шрифты. Откроется окно, где есть кнопка «brovse», через которую мы находим необходимый ibk-файл, жмем ок, он попадает в список шрифтов, оформленных, как дерево, на него приходим и жмем добавить (add), он появляется в списке добавленных шрифтов, делаем его по умолчанию и жмем ок.

    Если хотим сделать с ним ещё что-то, то там же есть кнопки «Изменить» и «Удалить».

Вот, собственно, и все.

Берем текст, отправляем его на винбрайль, для чего в пункте меню «Отправить» из моего компьютера появляется соответствующая кнопка, либо же открываем его из самого винбрайля, компилируем текст из меню «braille», или нажимая на соответствующую комбинацию, а при автоматической отправке он и сам компилируется, если текст большой, ждем некоторое время (ход компиляции можно посмотреть джавс-курсором). В откомпилированном тексте (только там, а не в оригинале) делаем нужное нам форматирование и бросаем на печать.

Если текст надо сохранить для дальнейшей распечатки, делаем это: в нужной папке появляется файл с расширением *.wbr, который и является нашим текстом.

При дальнейшем открытии прочитать джавсом его не удается, потому так сохранять можно только уже полностью правленные тексты, которые в дальнейшем будут только распечатываться.

Также я заметил, что и тексты формата *.txt, открытые винбрайлем читаться не будут, только джавс-курсором, что, сами понимаете, крайне неудобно.

Насчет читабельности этих текстов Брайлевским дисплеем ничего сказать не могу.

Как сдружить винбрайль с конкретным принтером

Не забудем, что у любого Брайлевского принтера есть свои настройки, которые, в большинстве случаев, будут доминировать при печати, потому их также нужно согласовать с настройками винбрайля.

Подробно о работе с Брайлевскими принтерами написано в «Руководстве пользователя», поставляемом с ними, в том числе и в аудиоформате, здесь же я лишь продемонстрирую значения своих настроек, а также скажу о некоторых небольших подводных камнях при печати через винбрайль.

Итак, пройдемся по значениям, которые у меня стоят в соответствующих группах.

Последовательный интерфейс:

  • скорость передачи – 9600,
  • биты данных – 8,
  • контроль – никакой,
  • стоп-биты – 1,
  • подтверждение – аппаратное;

группа «Форма страницы»:

  • знаков в строке – 36;
  • левое поле – 0;
  • поле переплета – 0;
  • верхнее поле – 1 (печатных строк на странице –26);
  • нижнее поле – 2 (печатных строк на странице – 26);
  • строчный интервал – 4.7 (печатных строк на странице – 26);
  • форма печати – обычная;
  • нумерация страниц и режим печати (односторонняя или двухсторонняя) меняются по надобности.

группа «Выбор»:

  • автоматический перенос слов – выключен;
  • автоматический перевод строк – включен;
  • новый лист – выключен;
  • сила удара – 5;
  • громкость – 1;
  • ожидание – 4;
  • скорость печати –1;
  • расстояние между точками (графика) – 2.5;
  • расстояние между точками (текст) – межстрочный2.5;
  • изменение установки – разрешено.

группа «Брайлевский код»:

  • язык – русский компьютерный 1;
  • компьютерный – шесть точек.

Вот, собственно и все группы.

Переносы я убрал, потому что винбрайль русских переносов решительно не понимает, чтоб не было некрасивых переносов, пусть лучше по несколько символов оставляет.

Как вы видели, строк на странице 26, не считая специальную строку для нумерации страниц, если она отключена, строка просто пустая, поэтому, так как в начале печати принтер выводит какие-то свои данные, то я ставлю специальный листок, в начале делаю столько-то ентеров, в зависимости от количества сторон и даю на печать, первый лист печатается с мусором, его можно использовать потом много раз, остальные же листы печатаются как положенно, лишь при нумерации страниц книга начинается с третьей страницы, но это не страшно.

Таблицы, если были не сложные, сильно не разбиваются, второй столбец первой строки таблицы пишется по-Брайлю под первым столбцом той же строки и т.д.

Пробелы между строками, например, для отделения заголовков, лучше писать в откомпилированном тексте, так как при компиляции они, скорее всего, будут съедены, как и все форматирование.

Щелкнув по следующей ссылке, можно загрузить архив с русским шрифтом для программы WinBraille: Загрузить русский шрифт (zip, ~8 Кб).
После загрузки архив нужно распаковать, а об установке шрифтов см. выше.

На этом пока все.



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2017