Windows 95 для незрячих и слабовидящих

Автор: Сара Морли (Sarah Morley)

Оглавление


Е МЕНЮ

Понятие Меню произошло от простого ресторанного меню. Вам подают список, из которого надо что-нибудь выбрать. Большинство Windows приложений имеют по несколько меню с разными названиями, включая Строку меню, Меню окна, выпадающие меню, а некоторые кроме того имеют еще и вложенные меню. Все они описаны ниже.

E1 СТРОКА МЕНЮ (ГЛАВНОЕ МЕНЮ)

Все Windows приложения управляются с помощью строки меню, в которую можно попасть стандартным способом. Строка меню( иногда называется главным меню) это линейка с пунктами меню верхнего уровня. Она расположена вдоль верхнего края приложения, и с ее помощью выполняются все операции по управлению этим приложением. Например, пункты меню текстового процессора обычно включают: Файл, Редактировать, Вид, Формат, Справка.

Все строки меню в Windows приложениях, написанных с учетом рекомендаций от Microsoft, будут выглядеть похоже. Тем не менее все приложения будут иметь еще и свои специфические пункты меню.

E 1.1 ВЫБОР ПУНКТОВ ИЗ СТРОКИ МЕНЮ

Строка меню обычно активируется клавишей Altили F10, при этом выделяется первый пункт меню.

В некоторых приложениях, которые не могут открыть более одного окна одновременно, первым пунктом может быть иконка меню окна, или пункт строки меню, Файл.

В приложении способном работать с несколькими окнами одновременно, нажатие на Alt или F10 выделит иконку Меню окна активного документа.

Выделение перемещается по пунктам строки меню с помощьюлевой и правой стрелки курсора.

Выделение перемещается по кругу. При перемещении выделения по пунктам строки меню и выпадающих меню в строке состояния появляется краткое описание того что, последует при выборе этого пункта. Это зависит от вашего экранного чтеца, сможетевы читать эти описания или нет.

E 1.2 ГОРЯЧИЕ ИЛИ УСКОРЯЮЩИЕ КЛАВИШИ

Пунктыв строке меню имеют горячие клавиши(ускорители), которые позволяют быстро выбирать пункт меню нажатием Alt плюс ускоритель. Например Alt+С для Справки, или Alt+Ф для Файла. Ускорители в названии пункта меню всегда подчеркнуты. Так что С вСправкеотрывает выпадающее меню помощь, а Ф в Файле открывает меню Файл. Нужно добавить, что некоторые команды имеют свои горячие клавиши - например в большинстве приложений Alt+Ф4 закрывает активное приложение пропуская строку меню(Как будто вы нажали Файл/Выход)

E2 ВЫПАДАЮЩЕЕ МЕНЮ

У большинства пунктов строки меню в приложениях есть выпадающие меню( вертикальные списки дальнейших опций характерных для выбранного пункта меню). Оно называется так потому, что буквально выпадает (разворачивается вниз) из пункта строки меню,и остается прямо под этим пунктом.

Например из пункта Файл выпадает меню, содержащее, как минимум, такие опции: Открыть, Сохранить, Печать, Выход.

Выполнение одной из опций выпадающего меню может повлечь за собой 3 варианта развития событий:

  1. Немедленное выполнение выбранной команды, например Выход.
  2. Открывается диалоговое окно запрашивая больше информации, или #li подтверждение на выполнение, например Сохранить
  3. Вызов подменю(каскадное меню). Если опция имеет подменю справа от нее нарисована стрелочка.

В выпадающем меню после нажатия левой или правой стрелки курсора возможно два варианта развития событий:

  1. Вы попадаете в следующее выпадающее меню. Например, в текстовом процессоре из выпадающего меню Файл в выпадающее меню Редактировать.
  2. Вы попадаете в каскадное меню, если опция была со стрелочкой.

E 2.1 ВЫБОР ОПЦИЙ В ВЫПАДАЮЩЕМ МЕНЮ

По умолчанию, когда открывается выпадающее меню, первая опция всегда выделена. Можно выбирать опции стрелками вверх и вниз, после чего, нажав Enter, запустить выбранную, а можно использовать ускорители.

E 2.2 ГОРЯЧИЕ КЛАВИШИ В ВЫПАДАЮЩЕМ МЕНЮ

Многие опции в выпадающем меню можно быстро запустить с помощьюускорителей, например П для Печать.При этом не нужно нажимать Alt вместе с ускорителем как в строке меню - в выпадающем меню просто нажимается один ускоритель. При нажатии Alt выпадающее меню исчезает.

E 2.3 СОСТОЯНИЕ ОПЦИЙ В ВЫПАДАЮЩЕМ МЕНЮ

Опция в выпадающем меню может служить в роли Включателя/Выключателя.

Напримеропция Стандартные в Вид/Панели инструментов обозначена птичкой (галочкой или флажком - кому как нравится), если панель Стандартные включена и не имеетптички, если панель отключена.

Каждый раз когда вынажимаете на такую опцию она переключается между состояниями Включен и Отключен. Например в Проводнике в меню Вид есть опция, которая включает и отключает строку состояния. С помощью этой опции вы выбираете, хотите ли вы видеть такую информацию как размер файла, оставшееся на диске место и т.д. или нет.

E3 КАСКАДНОЕ МЕНЮ (ВЛОЖЕННОЕ МЕНЮ)

Подменю, в которое вы попадаете из выпадающего меню, называются каскадным или вложенным. Если справа от пункта меню стоит стрелочка, значит у него есть вложенное меню. Например, Автотекст -->. Нажав здесь Enter или правую стрелку вы попадаете во вложенное меню. Оно появляется справа от выбранного пункта и предлагает вам дальнейший вертикальный список пунктов, в котором можно работать как в обыкновенном выпадающем меню. Чтобы вернуться в родительский пункт меню, достаточно нажать левую стрелку или Escape.

В простых текстовых редакторах как, например, в Блокноте есть только строка меню и одноуровневые выпадающие меню, а затем сразу уровень выполнения или появление диалогового окна, но в более сложных приложениях типа Word придется пройти несколько уровней меню и диалоговых окон, прежде чем достигнуть уровня выполнения.

E4 ЧТО МОЖНО УЗНАТЬ ИЗ НАЗВАНИЯ ПУНКТА МЕНЮ?

В выпадающих, всплывающих и вложенных меню многих приложений рядом с пунктом меню ставится символ, который дает знать, что произойдет при выборе этого пункта.

  • нет символа:означает, что вы сразу запускаете команду на выполнение. Например, Закрыть.
  • три точки: появляется диалоговое окно, в котором вас, например, могут спросить какой файл открыть.
  • стрелка вправо: указывает на наличие вложенного меню.

E5 БЕЗДЕЙСТВУЮЩИЕ ПУНКТЫ МЕНЮ

Иногда пункты выпадающих меню не могут выполнять свои функции. Такие пункты называются "бездействующими" (bили недоступными, или заблокированными) и помечаются серым цветом (действующие обычно черного цвета). Так делается для того, чтобы мы не пытались выполнить бессмысленные операции. Например, в меню Редактировать пункт Вставить будет бездействующим до тех пор, пока вы не выполните команду Копировать или Вырезать, чтобы занести данные в Буфер обмена. Если Буфер обмена пуст, значит из него вставлять нечего, поэтому команда Вставить помечена серым, как бездействующая. Она станет действующей как только вы занесете в Буфер обмена данные.

E6 ОТМЕНА ВЫЗОВА МЕНЮ

Чтобы отменить вызов меню текущего уровня достаточно нажать Escape. Если вы находитесь во вложенном меню, отмена закроет его и возвратит вас в родительский пункт меню(для этой же цели служит левая стрелка курсора). Escapeвсегда возвращает вас на предшествующий уровень меню или отменяет вызов строки меню. Altотменяет вызов всех меню.

E7 ДОСТУП К МЕНЮ ОКНА (СИСТЕМНОЕ МЕНЮ)

У каждого окна есть меню, которое предлагает вам различные операции для изменения размера и расположения окна. Оно называется Меню окна, а иногда Системным меню. В зависимости от конкретного окна эти операции обычно включают: Восстановить, Переместить, Размер, Свернуть, Развернуть, Закрыть. Очень часто они имеют собственные акселераторы( комбинация быстрого вызова), например В для Восстановить, а некоторые также и горячие клавиши, чтобы миновать вызов меню, как, например, Alt+Ф4 для закрытия окна приложения, и Ctrl+F4для закрытия окна документа.

Окно приложения (родительское) и окно документа (дочернее) имеют свои системные меню, так что вы можете контролировать каждое окно в отдельности.

Меню окна родительского приложения называют Меню программы, и попадают в негоиз Строки меню -- используя стрелки вы перемещаете выделение на иконку Меню окна, которое на самом деле появляется на заголовке окна. Вы можете использовать комбинацию клавиш Alt+Spacebarдля мгновенного открытия Меню программы.

Меню Окна дочернего документа называется Меню документа. Можно стрелками переместить выделение по Строке меню на иконку Меню окна(оно окажется на строке меню), а можно воспользоваться комбинацией клавиш Alt+Дефис.

В отличие от Windows 3.1 диалоговые окна больше не имеютсистемного меню и поэтому их можно только закрывать.

E 7.1 ВЫБОР ПУНКТОВ ИЗ МЕНЮ ОКНА.

Меню окна - это самое обыкновенное выпадающее меню, поэтому для выбора пункта нужноиспользовать стрелки курсора и Enter или комбинацию клавиш.

Пункты Меню окна включают:

  • Восстановить(В),а так как это первый пункт и уже выделен, достаточно Enter;
  • Переместить(Е),
  • Размер(М),
  • Свернуть,
  • Развернуть(X )
  • Закрыть(З) или Alt+Ф4

E8 КОНТЕКСТНОЕ МЕНЮ ОБЪЕКТА

Многие объекты Windows 95 решают специфические задачи. Чтобы ускорить выполнение этих операций, объекты получили собственные меню. Их называютКонтекстным меню, Меню свойств, Меню ярлыка, Меню правого щелчка.

Контекстное меню доступно у многих объектов включая Панель задач, элементы диалоговых окон,иконки на Рабочем столе, сам Рабочий стол, файлы и папки в Проводнике. Оно представляет собой меню, которое всплывает где-нибудь возле своего объекта. Оно так и называется всплывающим. В зависимости от объекта набор операций в этом меню может изменяться. Чтобы вызвать Контекстное меню объекта:

  • убедитесь, что объект выделен
  • Нажмите Shift+F10 или щелкните правой кнопкой мыши. Если у вас Windows клавиатура, достаточно нажать на кнопку Контекстного меню( третья справа от Spacebar)

E 8.1 ВЫБОР ПУНКТОВ В КОНТЕКСТНОМ МЕНЮ

Контекстные (всплывающие) меню, в общем, ничем не отличаются от других , поэтому и выбор пунктов в Контекстном меню осуществляется также: либо стрелками курсора вверх вниз и затем Enter либо ускорителем, который обозначается подчеркнутой буквой в названии пункта.



Предыдущая глава| Следующая глава| Оглавление
Как подключить розетку.

Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2019