Начало работы в виртуальной студии Cakewalk SONAR

(Работа представлена на конкурс к десятилетию портала «Компьютерные технологии для незрячих и слабовидящих».)
Дата публикации:19.09.2014
Twitter Facebook Vkontakte

Введение

На сегодняшний день, чтобы незрячему человеку заниматься музыкой, нужен лишь современный компьютер с операционной системой Microsoft Windows, программа экранного доступа JAWS и Audio/MIDI-секвенсор, плюс некоторое внешнее оборудование, и, самое главное, талант исполнителя, аранжировщика, музыканта.

Внешняя или внутренняя звуковая карта?

Если мы, например, хотим записывать свой голос, нам, не считая, собственно, компьютера и микрофона, понадобится звуковая карта, имеющая:

  1. аппаратное Asio (Далее поясню для чего всё это нужно);
  2. микрофонный вход для конденсаторного микрофона с фантомным питанием;
  3. линейный вход, с помощью которого мы сможем подключать другие музыкальные инструменты, например синтезатор, гитарный или вокальный процессор эффектов, также линейный вход пригодится, если нам захочется оцифровать старые записи с бобинного магнитофона, и т.д.;
  4. инструментальный вход HiZ, если мы хотим использовать программные виртуальные гитарные процессоры.

Микрофонных и линейно инструментальных входов на карте может быть много. Для домашней записи, если вы музицируете один, обычно хватает одного микрофонного и одного линейно-инструментального входа. Если вы хотите записывать группу музыкантов одновременно, то вам необходима звуковая карта, которая имеет несколько входов : 4,8 и больше. На картах подобные входы могут называться Line In, Mic In или Line Microfone Imput,hi.z.

Если есть вход, значит, должен быть и выход. Выходы на звуковых картах, разумеется, тоже есть, к ним мы подключаем колонки или наушники, причём при покупке звуковой карты обязательно обратите внимание на раздельную регулировку уровней мониторной линии: колонок и наушников.

Выходов на звуковой карте также лучше иметь несколько, так как возможно вам понадобится подключать мониторы ближнего, среднего и дальнего поля или несколько пар наушников.

Некоторые устройства умеют работать в режиме каскадирования ( допустим карта RME Fireface 800 имеет 4 микрофонных и 10 линейных входов и, подключив две такие карты для записи, мы получим входов в 2 раза больше, но это довольно дорогое решение).

Такой режим поддерживают некоторые карты от Roland. Относительно бюджетным решением с микрофонным и линейно-инструментальным входом может выступать карта Roland UA-55 Quad-Capture, это внешняя звуковая карта подключаемая по usb 2.0. Также подобные карты есть у фирм Мaudio, FOCUSRITE, Creative Professional E-Mu, и многих других.

Современные решения таких аудио интерфейсов, как правило, не требуют внешнего питания, её можно взять с собой вместе с ноутбуком или планшетным ПК.

Есть и другой тип подключения, использующий порт Ieee1394 или попросту FireWire. У многих производителей, как правило, имеются карты с разным типом подключения, но покупка звуковой карты с FireWire интерфейсом сопряжена с неким риском в плане стабильности, так как зачастую FireWire-чип , встроенный в материнскую плату, не самый лучший. Многие производители рекомендуют покупать FireWire контроллер на чипе Texas Instruments, но зачастую его не так просто найти.

Мне в своё время в этом вопросе помог сайт nclabs.ru.

Не буду вас сильно пугать. У многих звуковые карты работают и на обычных чипах от Via, так что экспериментируйте. Есть карты, которые подключаются непосредственно к материнской плате по шине PCI /PCIE. Такие карты либо вообще не имеют предусилителей для микрофона и гитары, либо карта состоит из двух блоков. Один блок подключается к PCI или PCIE-слоту материнской платы и цифровым кабелем соединяется с внешним настольным блоком, имеющим микрофонные и линейно-инструментальные предусилители. Яркий пример такой карты - Creative Professional E-Mu 1616m.

При выборе карты поинтересуйтесь, какую операционную систему поддерживают драйверы звуковой карты, так как сейчас многие звуковые карты не работают с Windows 8.

Внешнее MIDI-оборудование

Для того чтобы играть и записывать партии, понадобится синтезатор, рабочая станция, MIDI-клавиатура или электронные барабаны.

Синтезатором у нас часто ошибочно называют рабочую станцию - "Workstation". Это устройство представляет собой законченное решение с клавиатурой, семплером и звуковым модулем с встроенным секвенсором. В нём уже вшиты разные тембры звуков и есть дорожки для записи партий, некоторые модели также имеют на борту и звуковую карту, подключаемую к компьютеру по USB-интерфейсу, например, Yamaha moX8. Интерфейс таких рабочих станций не очень удобен для незрячих, так как по большей части основан на многоуровневых меню с использованием минимума физических клавиш, хотя к чести упомянутой Yamaha, на их устройствах много кнопок, и вполне можно всё это запомнить, плюс есть программа для частичного управления этим синтезатором, которая на данный момент читается программами экранного доступа.

Синтезатор, в чистом виде, представляет собой устройство с клавиатурой, а зачастую и просто рековый звуковой модуль, не имеющий возможности записывать партии, имеющий различный тип синтеза.

MIDI-клавиатура для студийных музыкантов является наиболее разумным решением, она не имеет звукового модуля и подключается к рековому звуковому модулю, другому синтезатору или секвенсору, в нашем случае таким секвенсором является компьютер с установленной программой Cakewalk SONAR. Устройство имеет клавиатуру, как у синтезаторов и рабочих станций, но, как правило, не имеет звукового модуля и секвенсора. В зависимости от стоимости, клавиатура может быть оснащена дополнительными органами управления: фейдерами, контроллерами, кнопками и колёсами модуляции и тона. Эти физические регуляторы могут использоваться для управления виртуальными или реальными устройствами, которые поддерживают протокол MIDI.

Установка Cakewalk SONAR

Прежде чем начать, стоит сказать, что для музыкальных программ вопрос выбора операционной системы является критичным, не советую ставить так называемые сборки Windows. Рекомендую использовать только чистые дистрибутивы Windows 7 32 или 64 бит. Если у вас больше, чем 4Гб памяти, лучше поставить 64-битную систему. В этом случае виртуальные семплеры смогут её использовать в полном объёме.

Официальный сайт программы SONAR: https://www.cakewalk.com/.

Весь дистрибутив SONAR размещается на четырёх DVD-дисках и включает в себя разные виртуальные vst-инструменты. Сама программа располагается на первом диске, и, если у вас включен автозапуск, у вас может появиться оболочка, использующая флэш элементы и музыку, которые недоступны с программами экранного доступа. Всё это смело можно закрывать.

Всё ниженаписанное актуально для SONAR 8.5.3, аналогично ставиться и SONAR 8.31, за исключением того, что для 8.5 после установки программы нужно сразу поставить скрипты JSONAR, так как без скриптов не будет озвучиваться первый диалог быстрого запуска.

Чтобы начать установку SONAR, нужно запустить файл setup.exe из папки install.

В первом диалоге для продолжения установки нам рекомендуют закрыть текущие программы. Нажимаем Next.

В следующем диалоге, если у вас 64-битная система, SONAR предложит сделать выбор между 32 и 64-битной системой, выбираем и опять же нажимаем next.

На следующем экране установки ставим флажки "I understand that I can install and use this software on only one machine at a time" и "I understand that I cannot transfer or sell this software". Также имеющуюся радиокнопку ставим в положение "I accept the terms in the License Agreement" и нажимаем Next.

Далее нужно ввести полученный при покупке серийный номер и нажать Next. Серийный номер может быть на коробке продукта.

В следующем диалоге нам предлагается выбрать тип установки Basic. Это базовая установка, SONAR установит все компоненты. Этот тип установки рекомендуется для новых пользователей, которые ещё не знакомы с программой. Advanced: это выборочная установка.

Выбираем Basic и нажимаем Next.

Далее нам предлагается выбрать папку, куда будет установлена программа. Если хотим сменить путь установки, нажимаем Browse и выбираем нужную папку. Если всё устраивает, то нажимаем Next, чтобы продолжить.

В следующем диалоге нам опять предлагают выбрать тип установки. Имеются 2 списка: в первом - типы, а во втором перечисляются элементы, с которых, если они нам не нужны, можно снять флажок. Также состояние флажков зависит от того, что мы выбираем в первом списке.

  • Recommended Installation - рекомендованная установка.
  • Full installation - полная установка.
  • Audio plugin - будут установлены только плагины обработки звука.
  • Soft Synths installation- будут установлены только виртуальные синтезаторы.
  • Minimal installation - минимальная установка.

Для начинающих пользователей опять же рекомендую оставить вариант по умолчанию Recommended Installation.

После того как определились с выбором, нажимаем Next.

В следующем диалоге стандартно предлагается создать группу в разделе Все программы, ничего не меняем и нажимаем Next.

Далее SONAR просит выбрать папку, куда он поместит свои компоненты, такие как MIDI-плагины, контрол сурфейсы и dx синтезаторы. Здесь тоже нажимаем Next.

На следующем экране инсталлятор просит выбрать папку, куда будут помещены VST плагины, в последствии все новые устанавливаемые вами плагины будут скорее всего устанавливаться именно в эту папку. Нажимаем Next.

В следующем диалоге программа предлагает выбрать путь для некоторых своих семплеров и ревербераторов. Оставляем по умолчанию и нажимаем Next.

На следующем экране мы выбираем типы файлов, которые будет открывать SONAR по умолчанию. Тут, например, можно поставить флажок на MIDI и тогда в проводнике или любом другом файловом менеджере именно SONAR и будет их открывать. После всех настроек жмём Next. В этом предпоследнем диалоге нам предлагается создать ярлык на рабочем столе, а также поставить некоторые дополнительные инкодеры. Ничего не меняем и нажимаем Next.

В последнем диалоге нажимаем Install, и начнётся процесс установки.

После того как всё скопируется на жёсткий диск, появляется диалог с двумя флажками "View the README file" - откроет документацию на английском. "Launch application" - запустит приложение, рекомендую пока их снять и нажать кнопку Finish.

После этого точно таким же образом нужно по порядку установить обновления:

  • Producer851Patch.exe,
  • Producer852Patch.exe,
  • Producer853Patch.exe.

Первый запуск и предварительная настройка

Перед тем, как поставить дополнение JSonar, необходимо один раз запустить SONAR. Перед нами появляется диалог

SONARPDR:

SONAR will now personalize your user settings by copying 
application data files.
This may take a few moments. Click OK to continue or Cancel to 
abort the personalization.

Нажимаем ok, и программа скопирует в папку с документами некоторые свои настройки.

Также SONAR вам предложит настроить звуковую карту и ввести регистрационный номер.

Когда появится диалог Quick Start, закрываем его комбинацией ALT F4 и этой же комбинацией закрываем саму программу, переходим к следующему шагу.

Установка JSonar

Для того чтобы программа экранного доступа JAWS должным образом озвучивала программу SONAR, необходимо поставить скрипты jSonar. Их можно скачать с сайта. Также на этом сайте вы найдёте программу и скрипты Native keys lite, которая помогает JAWS работать в окнах виртуальных синтезаторов и эффектов. По ходу статьи я опишу как работать с Native Keys.

Особых пояснений по установке JSonar не требуется. Следите за языками JAWS и языками JSonar, там есть русский.

Также настоятельно рекомендую ознакомиться с документацией по JSonar, все проблемы, которые могут у вас возникнуть, там, скорее всего, уже описаны.

Документацию можно найти через "Пуск-Все программы- Документация".

Настройка SONAR

Опять запускаем SONAR, перед нами появляется диалог Quick Start.

В этом диалоге можно быстро открыть проект. Клавишами со стрелками вверх и вниз мы перемещаемся по пунктам:

  • Open Project - открыть проект.
  • Open a Recent Project - открыть последний проект.
  • Create a New Project - создать проект.
  • Online Videos and more - посмотреть обучающие онлайн видео на английском.
  • Getting Started - получить советы по быстрому старту.

Я обычно этот диалог отключаю, переключая "SHOW THIS AT STARTUP on" в состояние off, и закрываю это окно, найдя вертикальными стрелками пункт Close.

Далее нажимаем комбинацию клавиш Ctrl+N, чтобы открыть новый проект. При этом, если двигаться курсором вниз -вверх или влево- вправо, JAWS нам должен читать треки и области трека.

Переключение между дорожками и шинами происходит при нажатии Shift+стрелкавверх, Shift+стрелка вниз.

Треки или, выражаясь по-русски, дорожки в программе SONAR бывают двух видов: audio и MIDI. Соответственно, на audio дорожку мы записываем источники, подключенные к входам звуковой карты, на MIDI-треки мы записываем информацию с подключенного синтезатора, MIDI-клавиатуры или любого другого MIDI-устройства. Подключаемые виртуальные инструменты формата VST представляют собой комбинацию этих двух треков.

Шины, к которым мы можем переходить по сочетанию клавиш Shift+стрелка вниз, являются треками, но без возможности на них что- либо записывать и служат для коммутации. Например, шины удобно использовать, если нам нужно одним эффектом обработать разные дорожки.

Теперь нажимаем Ctrl + Insert + r и в диалоге соглашаемся с настройкой контрол сурфейса.

В случае с неудачной настройкой идём в меню Options / Controllers/Surfaces. Клавишей Tab доходим до списка и проверяем там наличие плагина Control Surface JSonar Control Surface. Если там ничего нет, нажимаем Tab и активируем кнопку добавления контрол сурфейса. Затем отыскиваем JSonar Control Surface, нажимаем Ok и закрываем этот диалог кнопкой Close.

Следите, чтобы в JSonar Control Surface в качестве устройства ввода не попала ваша MIDI-клавиатура. Следствием нормальной работы в списке с JSonar Control Surface считается надпись "in port none, out port none". Если миди-клавиатура всё же попала в качестве устройства ввода, проще всего в диалоге Control Surface удалить этот плагин кнопкой Delede и ещё раз добавить как описано выше.

Чтобы закрыть этот диалог, клавишей Tab доходим до кнопки Close. Затем повторно проходим процедуру настройки, нажав Ctrl+ Insert +r.

Теперь нам необходимо настроить панели SONAR. Для этого идём в меню Views / Toolbars и ставим там флажки на всём, кроме

  • a. Sync
  • d. Transport (Large
  • e. View
  • h. Event Inspector
  • i. User1
  • j. User2
  • k. user 3
  • allow wrap

После всех настроек нажимаем кнопку Close.

Также в меню Views нужно отключить Enable Tabbing for Open Views.

После этого у нас, помимо окна дорожек, появятся дополнительные окна, такие как Media Browser и Synth Rack. Переключаться между открытыми окнами комбинацией Ctrl+ Tab, а закрывать эти окна Ctrl + F4.

Я бы именно так и советовал поступить: позакрывать ненужные, и впоследствии сохранить шаблон проекта, но об этом чуть позже.

Бывает такое, что пункт Enable Tabbing for Open Views включен и в окне Event List. Проверить это легко: у нас в проекте по умолчанию 2 трека аудио и миди, навигация по трекам происходит вертикальными стрелками. Встаём на MIDI-трек, открываем окно Event List из меню Views, вставляем одну ноту, жмём Insert+3, чтобы пропустить клавишу и потом - Insert, чтобы вставить ноту. Также в настройках JAWS можно освободить одну из клавиш Insert в разделе центр настроек JAWS.

После того как мы вставили ноту, идя курсором вправо, мы должны слышать некоторые свойства: ноты, дорожки, часы, секунды, кадры, такт, доля, тик, канал и т.д. Если это окно читается, значит, всё в порядке. Закроем его по Ctrl F4.

SONAR при каждом запуске проверяет папку с vst-инструментами и плагинами на наличие новых. Я советую это отключить, так как это, как минимум, сэкономит время при запуске. Для этого идём в меню Options / Global, попутно, так как это требует документация JSonar, на вкладке General снимаем флаг с Enable X-Ray, Ctrl+Shift+Tab переходим на вкладку VST Plug-Ins. Именно тут и происходит работа с новыми VST-плагинами.

Кнопкой Add тут можно добавить новую папку, где у нас лежат инструменты или эффекты, а нас сейчас интересует флажок Scan For VST Plug-ins On Startup.

Вот его и снимаем. Теперь SONAR при запуске не будет сканировать папки на наличие новых VST-плагинов. Это нужно будет делать вручную, нажимая кнопку Scan VST Folders.

Также я советую на вкладке Audio Data поставить флажки Use Per-Project Audio Folders. При сохранении проекта делаем папку Аудио, куда и будет помещаться записанное через микрофон или линейный вход. Флажок On Startup Load Normal Template означает, что при загрузке SONAR будет загружаться новый проект с шаблоном Normal.cwt. Также на этой вкладке настраивается битность записываемых audio-данных Record Bit Depth.

После всех настроек нажимаем кнопку Ok.

Если у вас есть MIDI-клавиатура или синтезатор, подключённый к MIDI-портам звуковой платы или посредством USB, то все эти устройства нужно задействовать через меню Options/MIDI Devices.

В первом списке отображаются устройства ввода, тут и нужно поставить на своей MIDI-клавиатуре флажок. Во втором списке находятся устройства вывода. Это может быть синтезатор звуковой карты или встроенный в операционную систему программный синтезатор от Microsoft, а также внешние MIDI-выходы. Если мы хотим их использовать, то их тоже нужно отметить клавишей Пробел.

Далее переходим к настройке звуковой карты, я уже упоминал, что карта должна иметь аппаратную поддержку Asio, что нам позволит играть на виртуальных синтезаторах, подключать микрофон, гитару и прочие инструменты, которые можно подсоединить к линейному входу и обрабатывать входящий звук в реальном времени VST эффектами.

В случае со встроенной в материнскую плату картой, например, обработанный сигнал или сыгранную ноту с MIDI-клавиатуры вы будите слышать не сразу, а через некоторое время, что неудобно для живого исполнения. Для того, чтобы задействовать Asio-драйвер карты, идём в меню Options /Audio, встаём на вкладку Advanced клавишей Tab ищем список Driver Mode и выбираем там Asio, также ставим флажки Share Drivers With Other Programs и Always Open All Devices. Далее переходим на вкладку Drivers. В списках мы увидим входы и выходы звуковой карты. При режиме Asio может использоваться только одна карта, поэтому если у вас более одного устройства поддерживающего Asio, то чтобы включить другое, в начале необходимо поснимать флажки со всех входов и выходов текущей звуковой карты. Далее нам нужно отрегулировать значение задержки Asio, для этого идём на вкладку General и нажимаем кнопку Asio panel.

В зависимости от программы к звуковой карте, это окно может озвучиваться JAWS, а может и нет. Тут, возможно, придётся обратиться за помощью. На многих картах в этом окне задержка в миллисекундах выставляется ползунком, чем меньше значение, тем, соответственно, и задержка сигнала с входа карты будет меньше.

Время задержки можно посмотреть всё на той же вкладке General, переместив JAWS-курсор в нижнюю часть окна и найдя там строки Total Roundtrip.

Теперь настроим раскладку окон. Для этого необходимо скопировать файл JSonar.CakewalkWindowLayout, который лежит в папке C:\Program Files (x86)\JSonar\extras в папку C:\Users\xxx\Documents\Cakewalk\SONAR 8.5 Producer\Sample Content, где xxx имя вашей учётной записи.

Затем идём в меню Views - Layouts и в списке выбираем JSonar, снимаем флажок When Opening a File, Load its Layout и нажимаем кнопку Load.

Рекомендуется проделывать эту операцию в больших проектах, если какие-то скриптовые функции не срабатывают.

Настройка проекта

Некоторые полезные настройки содержатся в меню Options - Project. На вкладке Metronome мы можем выбрать, как будет генерироваться звук посредством audio или MIDI. Делается это переключением радиокнопки

  • Use Audio Metronome
  • Use MIDI Note

Первые 2 флажка на вкладке Metronome отвечают за то, будет ли метроном работать во время записи или воспроизведения.

В поле Record Count-in: прописывается, сколько тактов метроном будет стучать в холостую. Это можно использовать, если нужно подготовиться перед записью.

Также на этой вкладке можно выбрать звук метронома и настроить громкость первого и последующих ударов.

Далее я расскажу как пересохранить шаблон проекта. Перед этим, находясь в Track View, убеждаемся, что раскладка дорожек переключена в состояние all, делается это сочетанием Shift+стрелка влево / вправо. Этим самым мы выбираем раскладку дорожки, то есть количество элементов, отображаемое на треке.

Пересохранение проекта по умолчанию

При запуске SONAR у нас загружается проект по умолчанию. Это происходит в том случае, если поставлен флажок On Startup Load Normal Template.

Этот шаблон проекта мы можем изменить под свои нужды, например, заранее вставить нужные эффекты, синтезаторы, нужные треки.

Некоторые настройки окон, панелей инструментов у нас уже сделаны. Чтоб пересохранить проект по умолчанию, идём в меню File - Save As. Открывается стандартный диалог сохранения, двигаемся один раз клавишей Tab, в списке "Тип файла" выбираем Template. Открываем папку Sample Content, которая находится по пути C:\Users\xxx\Documents\Cakewalk\SONAR 8.5 Producer\Sample Content, где xxx имя вашей учётной записи.

Далее находим и пересохраняем файл Normal.cwt и соглашаемся на перезапись, нажав кнопку "Да".

Работа в проекте

Если вы не изменяли шаблон проекта по умолчанию, у вас в проекте есть два трека audio и MIDI. Навигация по трекам осуществляется вертикальными стрелками, а навигация по областям дорожки горизонтальными.

Если мы, стоя на последней области текущего трека, нажмём один раз стрелку вправо, мы попадём на имя следующего трека.

На audio-трек мы можем записывать аудио с линейного входа или подключенного микрофона, вставлять синтезаторы и импортировать audio данные.

Рассмотрим элементы управления аудио и MIDI-треков, они весьма похожи.

В первом поле, в данном случае audio, это имя дорожки. Нажав Enter или f2, его можно изменить. Также чтобы попасть в это поле, можно использовать сочетание клавиш Ctrl +Shift+N (при одиночном нажатии JAWS сообщает нам имя дорожки, при двойном - переходит на него).

Мют и Соло. - сочетание Ctrl+точка и Ctrl+slash.

Для того, чтобы узнать состояние этих кнопок и на каких треках это включено, можно нажимать Ctrl+Shift+точка и Ctrl+Shift+slash, а сочетание Alt+Shift+точка и Alt+Shift+Slash выключает эти кнопки на всех треках независимо от выделения, а при двойном нажатии включает на всех треках.

Кнопка Record сочетание - Ctrl+точка с запятой во включенном состоянии разрешает запись на треки, если у вас подключено много микрофонов и инструментов. Её нужно активировать на каждом треке.

SONAR можно настроить таким образом, что при записи на MIDI-трек кнопку recording можно и не нажимать, а просто запись будет производиться на активный в данный момент трек. Для этого ставим флажок в меню options/Global/Allow MIDI Recording without an Armed Track.

Кнопка Input Echo включает сквозной мониторинг. Это нам может понадобиться, если мы хотим в реальном времени услышать работу подключенного к треку плагина эффектов. В общем, нажимайте эту кнопку каждый раз, когда хотите поиграть на гитаре со вставленным плагином guitar rig или любым другим виртуальным процессором эффектов, а также когда поёте или говорите в микрофон и хотите слышать свой голос со всей обработкой эффектов, подключенной на трек.

При таком подходе прямой звук с микрофона или подключенной гитары нужно отключить, делается это по-разному в зависимости от звуковой карты. На некоторых, в частности, TC Electronic Konnekt 6, это делается физическим регулятором на карте imput / daw. При его крайнем левом положении мы слышим только подключенный микрофон или инструмент, но звука идущего из SONAR или любой другой программы нет. В крайнем правом не слышим прямой сигнал с микрофона или инструмента, а только то, что проходит через SONAR. Соответственно, соотношение сухого сигнала и звука идущего с программы можно балансировать.

Также для отключения прямого мониторинга в некоторых звуковых картах нужно искать настройку Derect Monitoring или Imput Monitoring.

Преимущество прямого мониторинга с карты заключается в том, что всё, что подключено к звуковой карте, проходит на выход без каких либо задержек. Это удобно, если вы используйте внешний аппаратный процессор эффектов.

Кнопка Archive приглушает трек, но в отличие от mute, фактически происходит отключение трека от проекта. При этом освобождаются занятые этой дорожкой ресурсы процессора и оперативной памяти.

Кнопка Freeze Synth замораживает дорожку синтезатора, сыгранная партия синтезатора переводится в Audio и происходит отключение dx / Vst-синтезатора. Это удобно использовать когда не хватает ресурсов процессора или оперативной памяти. В последствии такой трек можно обратно разморозить, нажав Unfreeze Synth.

Следующая область трека - это индикатор пиков.

Automation Read Enable - чтение автоматизации на треке.

Записью автоматизации называется изменение параметров трека, синтезатора или эффектов. Мы можем в реальном времени регулировать громкость на треке, и все эти изменения запишутся и будут проигрываться каждый раз. Соответственно, кнопка Automation Read отвечает за то, будет ли при воспроизведении трека учитываться такая автоматизация. Следующий параметр Automation Write Enable отвечает за запись автоматизации.

Каждый раз, когда нам нужно прописать какие-то изменения параметров, мы должны нажимать эту кнопку и при воспроизведении посредством аппаратного MIDI-контроллера или непосредственно с компьютерной клавиатуры изменять те или иные параметры.

Volume громкость audio или MIDI-трека.

Следующая секция трека, где JAWS говорит область эффектов, служит для подключения синтезаторов или эффектов. Быстро попасть в это поле можно, нажав Ctrl+Shift+F дважды.

В этом поле, чтобы выбрать эффект или VST-инструмент, нужно нажимать Applications и в подменю Audio FX или Soft Synths выбрать необходимый эффект или VST-инструмент. Подробнее об этом будет ниже.

Pan служит для изменения панорамы звука. Регулируя это значение, можно уводить дорожку в левый, правый канал или по центру.

Trim- громкость, может использоваться для усиления.

Input - в этом контекстном меню выбирается входной источник.

В случае с audio-дорожкой тут может выбираться вход звуковой карты, с которого мы хотим записывать. Если в проект вставлен многоканальный vst-инструмент, тут может выбираться его выход, речь идёт именно об audio-выходах. В случае с MIDI-дорожкой выбирается MIDI-клавиатура или любое другое MIDI-устройство.

Output To - это выход дорожки. В случае с audio-дорожкой тут может выбираться шина или непосредственно выход звуковой карты.

У MIDI-трека в этом контекстном меню выбираем, на какой VST-инструмент мы направляем все записанные данные, а также всё то, что поступает на вход трека.

Последние 2 секции у audio-трека это

Phase - фаза и Interleave кнопка, переключающая дорожку в моно или стерео.

У MIDI-трека имеются ещё некоторое количество параметров. Рассмотрим самые важные из них:

  • Input Quantize- включает или отключает квантизацию при записи.
  • Input Quantize Resolution- в контекст меню на этой области выбирается, к каким длительностям с точки зрения позиции и длительности будут подтянуты ноты .
  • MIDI Channel- в контекст меню выбирается MIDI-канал.

Большинство современных vst-инструментов являются одноканальными, но есть и такие, что умеют работать, используя все 16 каналов, то есть, загрузив 1 такой VST-инструмент, мы можем записать 16 MIDI-треков.

Ярким примером такого виртуального инструмента является входящий в поставку программы синтезатор Cakewalk TTS-1, а также семплер Native Instruments Kontakt 5, который может быть доступен при использовании скриптов Native Keys Pro.

Bank- в этом поле мы выбираем банк инструмента. К сожалению, на данный момент всё меньше инструментов поддерживают выбор банков по средствам этого поля, но упомянутый Cakewalk TTS-1 умеет это делать и тут мы можем выбирать его банки. В следующем поле

Patch: мы выбираем инструмент.

Банки и патчи удобнее листать через меню Track Properties. Этот пункт можно найти в контекстном или расширенном меню, которое открывается при нажатии клавиш Ctrl+application. Правда, при выборе пункта Track Properties - свойства трека на первый план иногда выходит диалог по настройке цветов. Его нужно закрывать клавишей Esc.

Также на MIDI-треке есть параметры

Key - регулирует тональность трека. Удобно использовать, если нужно быстро поднять / опустить партию на октаву или любое другое значение в полутонах.

Time- сдвигает трек по времени.

Параметры Chr и Rev регулируют степень эффектов Chorus и реверберации, но будет ли это работать, зависит от конкретно вставленного VST-инструмента.

Работа с программой Native Keys Manager

Вы можете скачать лайт версию скриптов Native Keys. Необходимо распаковать архив в удобное место и запустить файл Native Keys Manager.exe. После первого запуска в последствии nk manager можно запускать из программы SONAR в меню Tools.

Эта программа позволяет, в частности, установить скрипты Native Keys Lite и Native Keys Pro, а также содержит ещё ряд дополнительных возможностей (подробности см. по кнопке "Справка" на вкладках).

Вкладка Native Keys

Здесь мы устанавливаем скрипты для SONAR и Reaper. Переключаем язык сообщений скриптов (английский или русский).

Чтобы установить скрипты NK для SONAR, в первом списке "Действия" должно быть выбрано "Установить для SONAR". Клавишей Tab перейдите в список "Установить Скрипты NK для". Здесь будет список установленных скриптов для SONAR.

Если установка происходит из-под JAWS, в списке будет выделена текущая версия JAWS и достаточно будет нажать клавишу F2, чтобы установить скрипты NK и подключить их к JSonar.

Если у вас более одной версии JAWS и установленных скриптов JSonar или вы устанавливаете скрипты из под NVDA или вообще вам их ставит зрячий без включенного скринридера, отметьте в этом списке нужные SONAR.jss флажками и нажмите кнопку Ok.

Вкладка JSonar

Тут мы чистим скрипты JSonar от горячих клавиш HSC или восстанавливаем горячие клавиши HSC.

Далее можно выбрать любую версию JAWS и её языковую папку и, если в ней установлены скрипты NK, мы можем их включить или выключить при помощи флажков в списке плагинов.

Также с этой вкладки мы можем скачать самые новые скрипты JSonar для SONAR 8 и 8.5 и для русифицированного SONAR 8.02.

Внимание! Это разные скрипты и, если вы перепутаете, то они ваш SONAR озвучивать не будут.

Вкладка SONAR

В первом списке показаны все VST-плагины, отсканированные сонаром. Флажками отмечены те из них, что сконфигурированы как синтезаторы или таковыми являются.

Кнопка Audition v1.5 позволяет подключить к сонару программу Adobe audition 1.5 в качестве внешнего аудио редактора.

Затем продублирован доставляющий много проблем флаг X-Ray. Он должен быть снят.

Далее идут 2 списка. В первом указаны версии программы SONAR, во втором - проекты выбранного сонара.

Вкладка Plug Ins

В первом списке перечислены некоторые из популярных плагинов, такие как Spectrasonic Omnisphere и StylusRMX, REFx Nexus и ряд других.

Вы можете при помощи NK менеджера подключить библиотеки без переустановки к этим плагинам или переместить корректно их на другой диск или раздел диска.

Кнопка KontaktToolForLibraries запускает утилиту работы с библиотеками самого популярного сэмплера Native Instruments Kontakt 5.

Подключение VST-инструмента в проект

Подключить vst-инструмент мы можем несколькими способами.

1. На audio-треке в области эффектов. Для того чтобы попасть в эту секцию, можно нажать Ctrl+Shift+F дважды и в контекстном меню в подменю Soft Synths выбрать нужный синтезатор, например, пусть это будет Cakewalk TTS-1.

Перед нами после этого появляется окно инструмента, в данном случае мы можем выбирать тембры этого плагина прямо с дорожки, поэтому чтобы закрыть окно плагина и вернуться в окно треков, нажимаем Ctrl+F4.

Затем мы должны, если у нас нет MIDI-трека, его создать. Делается это выбором пункта Insert MIDI Track из расширенного контекстного меню, которое открывается сочетанием Ctrl+application.

Для вставки треков и ещё некоторых событий служит меню Insert, там вы найдёте такие пункты как

  • Audio Track
  • MIDI Track
  • Multiple Tracks -это диалог для вставки нескольких треков.

Встаём на созданный или уже имеющийся MIDI-трек и в его секции Output в его контекстном меню, которое открывается при нажатии Enter, и выбираем тот VST-плагин, который вставили в проект.

Чтобы быстро попасть в этот список, можно нажимать Ctrl+Shift+Alt+O.

В секции MIDI Channel выставляем, например, первый канал и в следующих двух элементах трека выбираются банки и сами тембры инструмента.

Значения этих полей можно менять, нажимая минус и равно, также нажимать Enter и вписывать значение с клавиатуры, но удобнее просто выбирать всё это из списков Bank и Patch через пункт Track Properties, который доступен из расширенного контекстного меню Ctrl+application. Также удобно использовать браузер патчей на миди дорожке клавиша.

Чтобы работать с ударными тембрами этого инструмента, необходимо выставить 10 MIDI канал или выбрать соответствующий банк. Вставка инструментов таким образом, конечно, удобна хотя бы тем, что, переместившись в область эффектов, мы видим вставленный инструмент и по нажатию Enter можем попасть в его окно. Но есть и ряд недостатков:

  1. Мы не сможем вставить на тот же трек плагин эффектов.
  2. Мы не сможем использовать многоканальный вывод каждого инструмента (о таких инструментах будет далее).

Теперь мы на примере виртуального инструмента Session Drummer 3 рассмотрим вставку инструмента в проект другим способом.

Для того чтобы вставить виртуальный инструмент таким образом, нам не нужны предварительно созданные треки, просто идём в меню

Insert / Soft Synths и выбираем там Vst-плагин Session Drummer 3.

При этом у нас появляется диалог Insert Soft Synth Options, о котором стоит поговорить отдельно.

Insert Soft Synth Options

Это диалог в котором настраивается то, как будет вставлен виртуальный инструмент.

Группа Create These Tracks:

1. Simple Instrument Track

Если отметить этот флаг, то в проект вставится только объединённая синтезаторная дорожка.

В последствии такой трек можно будет всегда превратить в обычную пару audio/MIDI, выбрав в расширенном контекстном меню пункт

Split Instrument Track.

2. MIDI Source. Создаётся классическая пара аудио и миди-дорожки. Её в последствии тоже можно превратить в один трек, нажав в расширенном контекстном меню

Make Instrument Track.

3. Synth Track Folder. Помещает все дорожки вставляемого vst-инструмента в отдельную папку. Не рекомендую это использовать, так как скрипты не корректно работают с такими объектами.

First Synth Audio Output - только первый аудио выход, то есть в проект вставится одна стерео дорожка. Этот флаг вставит всё почти так же, как при вставке синта через область эффектов, но выходы многоканальных инструментов будут доступны и мы можем подключить к ним другие треки.

4. All Synth Audio Outputs: Stereo - все аудио выходы стерео. Если отметить этот флажок, то в случае с многоканальным инструментом будут задействованы все выходы инструмента. Соответственно, будет создано количество audio-треков равное количеству выходов плагина.

All Synth Audio Outputs: Mono - все выходы будут представлены моно дорожками.

Группа Open These Windows:

Synth Property Page - открывает окно инструментальной панели Плагина Synth Rack View. Наряду с окном плагина, Открывает окно Synth Rack.

Enable MIDI Output - создаёт MIDI-трек.

Display Automation On: - дисплей автоматизации

Recall Assignable Controls - установите этот флаг, если нужно чтобы сонар запоминал отмеченные флажки. Правда, иногда они всё же сбиваются, непонятно почему.

Ask This Every Time - каждый раз показывать этот диалог. Сняв этот флажок, при вставке виртуального инструмента мы сразу будем попадать в его окно, если, конечно, пункт Synth Property Page был отмечен. Вызвать этот диалог всегда можно через окно Synth Rack, нажав в нём o.

Для того чтобы при вставке VST-плагина появлялась 2 трека audio и MIDI, ставим следующие флажки:

  • MIDI Source
  • First Synth Audio Output
  • Synth Property Page
  • Enable MIDI Output
  • Recall Assignable Controls.

Для закрытия диалога нажимаем Ok или прямо на любом флажке - Enter.

В итоге, у нас открывается окно плагина Session Drummer 3.

Если вы установили скрипты Native Keys Lite или Native Keys Pro, следствием того, что скрипты работают правильно, при нажатии Insert+H будет открытие справки активного в данный момент VST-плагина. Это актуально как для инструментов, так и для эффектов. Чтобы узнать, поддерживают ли скрипты Native Keys тот или иной плагин, достаточно нажать Insert+H.

Или нажать Alt+Windows+Control+A: в этом случае в виртуальный просмотр будет выведена информация о всех поддержанных проектом Native Keys плагинах SONAR и Reaper.

Session Drummer3 - это барабанный семплер в него можно загружать семплы формата wav, он содержит в себе готовые барабанные установки, которыми мы сейчас и воспользуемся.

Для открытия дерева с барабанными установками нажимаем Alt+Aplication.

Откроется дерево, где барабанные установки представлены по стилям. Выбираем, например, Acoustic - SmartLoops_GroovyKit.prog и для загрузки семплов в оперативную память нажимаем Enter. Чтобы закрыть это дерево, жмём Alt+F4. При этом окно плагина останется в фокусе.

По умолчанию все семплы барабанов этого инструмента выводятся на одну стерео audio-дорожку, но есть возможность каждый из барабанов послать на свой отдельный audio-трек, чтобы позже, например, обработать эффектом отдельно от всех барабанов.

вот как это делается: после того как в дереве выбрали нужную установку, нажимаем M, чтобы попасть на страницу Mixer. Это микшерная панель, тут можно отрегулировать громкость, панораму, ширину каждого барабана, а последним из параметров и будет выбор, на какой аудиовыход направлять звук.

Сначала мы должны выбрать тот барабан, с которым хотим работать. Для этого нажимайте цифры от 1 до =. Затем стрелками влево / вправо двигаемся до того, как JAWS скажет контекст-меню audio выходов барабана. Быстро попасть в это меню можно, нажав Shift+5.

Затем нужно вертикальными стрелками открыть это меню и выбрать нужный выход. После этого окно плагина можно закрыть по комбинации Ctrl+F4.

Если в диалоге вставки плагина был отмечен флажок First Synth Audio Output, то у нас вставилось только 2 трека MIDI и audio, которые называются так же, как и VST плагин.

Нам нужно создать ещё один audio-трек и в его секции Input в появившемся меню зайти в подменю SessionDrummer x64 и там выбрать соответствующий выход VST-плагина.

Чтобы удалить вставленный vst-инструмент из проекта, если вы ничего не делали после вставки, можно воспользоваться командой Undo. Эта функция отменяет последнее действие.

Также виртуальный инструмент можно удалить в окне Synth Rack. Быстро попасть в это окно можно, нажав Alt+F8, но чтобы эта команда сработала, нам необходимо очистить скрипты JSonar от горячих клавиш HSC. Это легко сделать, если у вас установлены скрипты Native Keys Lite или Native Keys Pro. Запускаем программу Native Keys Manager, которая находиться в меню Tools и переходим на вкладку JSonar.

Двигаясь клавишей Tab, убеждаемся, что в списке действия установлено Очистить JKM. В следующем списке отмечаем флажком ту версию JAWS, с которой работаем, и нажимаем кнопку ОК.

vst-инструменты в окне Synth Rack удаляются клавишей Delete. В версии SONAR 8.5.3 это окно не озвучивается и, перемещаясь вертикальными стрелками, можно играть на MIDI-клавиатуре и исходя из того какой тембр вы слышите и делать вывод о том, на каком vst-инструменте вы стоите.

Запись и работа с транспортной панелью

После того как были найдены необходимые тембры инструментов, чтобы произвести запись, достаточно нажать Ctrl+точка с запятой. JAWS должен сказать "рэк". Затем надо нажать r для начала записи. Режим записи выбирается в диалоге, который открывается сочетанием клавиш Alt. Если выбран режим Sound On Sound, то всё, что вы играете, будет накладываться друг на друга.

Overwrite - при каждой записи удаляет всё, ранее записанное. Останавливать запись, воспроизводить / останавливать проект - клавиша Пробел. Ctrl+Пробел ставит проект на паузу. Перемещение по тактам осуществляется клавишами Ctrl+Page up и Ctrl+Page down. Перемещение по долям - Shift+page up, Shift+page Down. JAWS при этом должен сообщать, на каком такте / доле мы стоим. При этом бывает такое, что внешние программы, такие как Skype / Skype Talking, могут мешать срабатывать этим функциям, поэтому следите за тем, какие сочетания горячих клавиш вы применяете в программах, которые запущены во время работы в SONAR.

Поведение программы при остановки проекта зависит от глобальной настройки

On Stop, Rewind to Now Marker, которая находится в меню Options/Global. Если этот флажок установлен, то при нажатии стоп проект перейдёт в начало текущей позиции. Текущая позиция может быть определена маркером или перемещением на нужный такт / долю или если во время воспроизведения поставить проект на паузу, нажав Ctrl+Пробел.

Маркеры в проект устанавливаются при помощи клавиши F11, а перемещение по маркерам происходит сочетанием клавиш Ctrl+Shift+page Up / Ctrl+Shift+Page Down.

Чтобы программа автоматически останавливалась в конце проекта, советую поставить флажок Stop At Project End, который находится всё в том же меню Global.

Копирование и вставка данных дорожки

Предположим, у нас записано 4 такта и мы хотим их скопировать ещё на несколько тактов. Для этого выделяем трек клавишей "запятая" в латинской раскладке. Устанавливаем начальный локатор на первый такт. Для этого мы должны встать на первый такт и нажать F9, затем встать на пятый такт и установить конечный локатор, нажав F10. Таким образом мы выделили 4 такта.

Затем сочетанием Ctrl+C копируем выделенный фрагмент. В появившемся диалоге следим за тем, чтобы был установлен флажок Events in Tracks. Это, собственно, записанные события. Нажимаем OK.

Далее, перемещаясь по тактам, встаём в то место, куда нам нужно вставить скопированный фрагмент, и нажимаем Ctrl+V.

В появившемся диалоге в первом поле будет написано, куда в тактах, долях, тиках будет вставлен наш новый фрагмент.

В поле Repetitions можно задать количество повторов. То есть если у нас выделено 4 такта и мы в этом поле напишем 3, то эти 4 такта будут вставлены последовательно трижды.

Следите за тем, чтобы флажок Link to Original Clip(s) был не установлен, так как работа со связанными клипами для нас не удобна и может запутать. После того как всё проверили, нажимаем кнопку ok.

Экспорт проекта в wav

Для того чтобы сохранить все сыгранные партии в один аудиофайл, иными словами, смикшировать все треки в один, нужно использовать команду audio из меню File/export. Перед этим нужно выделить все треки сочетанием Ctrl+A и установить начальный локатор в начало проекта, а конечный - через несколько тактов после последней ноты проекта. Таким образом у нас не обрежутся хвосты нот в конце проекта. Напомню, начальный локатор устанавливается клавишей f9, конечный - f10.

При открытии диалога Export Audio открывается стандартный диалог сохранения. Следите за тем, чтобы в имени файла не было звёздочек.

В секции "Тип файла" выбирается тот формат, в который мы хотим сохранять.

В списке Source Category можно выбрать, как будут экспортироваться наши дорожки. Entire Mix - все треки в один файл ( именно так и выбрано по умолчанию). Можно сохранить каждую дорожку в отдельный файл, выбрав Tracks, а также mix с выходов шин.

Нам предлагается выбрать частоту дискретизации "Sample Rate", битность "Bit Depth" а также выбрать папку, куда будет сохранён наш файл.

В этом окне есть ещё некоторые настройки, но они, как правило, не требуют изменений.

Mix Enables Track Mute/Solo - если снять этот флажок, то все треки, где нажаты кнопки Mute и Solo, тоже будут смикшированы в конечный микс или сохранены отдельными треками в зависимости от того, что выбрано в списке Source Category.

Mix Enables Track FX - если снять этот флажок, вставленные виртуальные эффекты учитываться не будут.

Mix Enables Track Automation - если снять этот флажок, записанная автоматизация на треке учитываться не будет.

Аналогично работают и все остальные флажки, но относятся к эффектам и автоматизации на шинах и клипах.

После того как всё настроили должным образом, для сохранения нажимайте кнопку Export и ожидайте окончания.

Сохранение проекта

Для того чтобы сохранить проект, достаточно закрыть программу и нажать кнопку "Да" или зайти в меню File и выбрать пункт Save As или просто Save, если проект уже сохранялся.

Также есть горячие клавиши Control+S. Это сочетание рекомендуется применять во время работы над проектом, чтобы не потерять данные в случае падения SONAR или выключения электричества.

По умолчанию SONAR предлагает сохранить проект в свой стандартный формат CWP, при этом у нас создастся папка Audio, куда будут помещены все записанные с внешних источников данные и сам файл с расширением CWP, поэтому рекомендую для каждого проекта делать отдельную папку.

Если мы хотим сохранить проект одним файлом, в котором будут содержаться MIDI и Audio- данные, то в секции "Тип файла" выбирайте Cakewalk Bundle.

Это удобно использовать, если есть необходимость переносить проект на другой компьютер.

Впоследствии сохранённые проекты можно открывать через меню File/Open или из списка в конце меню File.

Заключение

В статье описаны лишь базовые действия в программе SONAR. Наряду с этим, программа предоставляет возможности по редактированию сыгранных нот через диалог Event List, пошагово вводить ноты в диалогах Step Sequencer и Step Record, понижать и повышать фонограммы, ускорять и замедлять записанные миди и аудиоданные, работать с звуковой дорожкой видео-клипа и многое другое.

По всем вопросам, которые у вас возникают касаемо программы SONAR, VST-плагинам и работы скриптов Native Keys, вы можете связаться с автором статьи по электронной почте или по skype.

Также можно связаться с главным разработчиком проекта Native Keys Виктором Гореловым по электронной почте или о skype.

Ознакомиться с работами незрячих музыкантов использующих SONAR, почитать статьи а также скачать некоторые vst-инструменты можно на нашем сайте.



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2017