Первые шаги в виртуальной студии Cockos Reaper

(Работа представлена на конкурс к десятилетию портала «Компьютерные технологии для незрячих и слабовидящих».)
Дата публикации:06.09.2014
Twitter Facebook Vkontakte

Введение

Я думаю, что у многих возникают потребности в редактировании аудиоматериала. Зачастую бывает необходимо подготовить любимую песню для рингтона, сделать громче или тише аудиокнигу или добавить музыкальное сопровождение. Вы бы хотели записывать подкасты? Или, может быть, Вы студент, и Вам нужно обработать записи с диктофона: убрать в них всё ненужное и, например, увеличить громкость или темп без потери тональности файла? Тогда программа Reaper - это то, что Вам нужно.

Если Вы начинающий пользователь компьютера, я советую прежде овладеть элементарными навыками работы в операционной системе Microsoft Windows, в web-браузерах, в почтовых клиентах, в программе Skype и в других программах ip-телефонии с использованием программ экранного доступа JAWS for Windows или Nvda. Немаловажным фактором при этом является хорошее знание латинской раскладки клавиатуры.

Что же представляет собой программа Reaper? Это виртуальная многодорожечная студия для работы с аудио и MIDI, написанная программистом Джастином Франкелом (Justin Frankel), который в соавторстве с Дмитрием Болтырёвым в 1997 году написал небезызвестный всем плеер Winamp, в 2000 году P2P-клиент Gnutella и абсолютно уникальную платформу для полностью зашифрованных коммуникаций в интернете, включая чат и обмен файлами WASTE. В 2005 году Джастин Франкел создаёт фирму Сockos, и уже к концу года появляется первая версия программы Reaper. Она позволяет записывать, редактировать, микшировать аудио, обрабатывать эффектами реального времени и подключать плагины формата vst и многое другое.

В этой статье я расскажу, как совершать элементарные действия над записанным или импортированным материалом. Для наших целей вполне хватит портабельной версии программы Reaper 3 и уже подключённого к ней плагина ReaAccess, написанного Иваном Себекиным. Это программное дополнение обеспечивает частичный доступ к Reaper с использованием программ экранного доступа JAWS, nvda, Window-Eyes.

Портабельную программу под Windows 7 64 бита и скрипты, необходимые JAWS, можно скачать по по этой ссылке.

Официальный сайт программы Reaper: http://www.reaper.fm/.

Сайт плагина ReaAccess: http://www.reaaccess.com/.

Русскоязычное сообщество пользователей: http://reaper.revizer.ru/.

Если Вы не хотите использовать портабельную версию, то можно скачать установочную. Но не рекомендуется устанавливать ReaAccess на Reaper версии 4, которая доступна на официальном сайте Reaper, так как в ряде случаев могут возникнуть проблемы. Установочную версию Reaper 3, плагин ReaAccess и подкасты, записанные Геннадием Зиновьевым, можно скачать с нашего сайта.

Настоятельно рекомендую прослушать подкасты и ознакомиться со всеми прилагающимися текстовыми заметками. В своём повествовании я буду использовать портабельную версию Reaper и раскладку сочетаний клавиш, разработанную Геннадием Зиновьевым.

Первоначальная настройка установочной версии Reaper

Если Вы используйте установочную версию, то после установки Reaper нужно инсталлировать плагин ReaAccess. Делать это нужно после того, как один раз запустили Reaper. В процессе установки ReaAccess следите за тем, чтобы путь папки со скриптами программы JAWS соответствовал её используемой версии. Также после установки рекомендую проверить, подключены ли скрипты. Для этого в меню JAWS (клавиши Insert +J) заходим в меню Параметры /Управление настройками приложений и в списке проверяем, установлены ли флажки на Reaper.

Те, кто использует портабельную версию, должны скопировать скрипты из папки Scripts/ JAWS в папку со скриптами. Найти её можно следующим образом: Меню кнопки Пуск/Все программы/JAWS/Файлы JAWS/Мои настройки. Или через проводник, или любой другой файловый менеджер найти путь с поправкой на ваш компьютер и версию JAWS. У меня этот путь выглядит следующим образом:

C:\Users\Администратор\AppData\Roaming\FreedomScientific\JAWS\13.0\Settings\rus

Папка AppData у вас может быть скрыта, поэтому нужно разрешить в Windows показывать скрытые файлы. В проводнике Windows идём в меню Сервис/Параметры папок, переходим на вкладку Вид и в дереве находим "показывать скрытые файлы, папки и диски" и пробелом переключаем в состояние "on".

Следующий шаг - конфигурация программы Reaper. Самый короткий путь - это применить настройки от Геннадия Зиновьева. Для этого воспользуемся архивом по ссылке: http://www.nativekeys.mostinfo.ru/alternativnaya-raskladka-klaviaturyi-v-reaper-9.html

В папке с первым подкастом Вы найдёте папку reaper_3, в которой есть конфигурационный файл configuration3.ReaperConfigZip, и его надо импортировать в Reaper. При первом запуске Reaper у вас может появиться окно лицензии, стоит подождать несколько секунд и нажать Escape. Далее Reaper попросит выбрать аудиоустройство. Речь о диалоге:

REAPER Error
There was an error while opening your audio hardware. 
Would you like to view your audio device configuration?

Пока нажмём "нет", так как всё равно после конфигурирования программы нам придётся вернуться в этот диалог.

Для импортирования конфигурационного файла идём в меню Options/Preferences, с помощью клавиши Tab находим дерево и поднимаемся на самый верх на пункт general, далее клавишей Tab ищем кнопку Import configuration и находим тот файл configuration3.ReaperConfigZip. В следующем диалоге нажимаем "ok" и далее нажимаем кнопку import.

Примечание: после того как мы импортировали конфигурационный файл, традиционная команда Alt+F4 не будет закрывать Reaper. Для этого используйте сочетание Ctrl+Shift+Alt+Esc или через меню file Quit.

После этого у Вас опять появится нам знакомый диалог:

REAPER Error
There was an error while opening your audio hardware. 
Would you like to view your audio device configuration?

Но в этот раз нажимаем "да".

Прежде чем продолжить, стоит упомянуть, что далее все действия в портабельной и установочной версии одинаковы. Reaper просит нас выбрать аудиоустройство, через которое мы будем записывать и выводить звук. Это именно тот диалог, на котором мы остановились, когда добавляли конфигурационный файл в установочную версию Reaper.

REAPER Error
There was an error while opening your audio hardware. 
Would you like to view your audio device configuration?

Нажимаем кнопку "да" и попадаем в настройки программы Preferences в пункт Device.

Если ничего подобного не произошло, клавишами Alt или F10 попадаем в строку меню, идём в меню Options/Preferences. В открывшемся диалоге клавишами Tab/Shift+Tab доходим до дерева, стрелками вниз/вверх доходим до пункта Audio и стрелкой вправо разворачиваем его. Далее вертикальными стрелками встаём на пункт Device. Если у вас встроенная звуковая карта типа Realtek, то после того, как в дереве встали на Device, нажимаем 5 раз Tab и попадаем в список audio system, где выбираем DirectSound, далее нажимаем 3 раза Tab и попадаем в список с вашими входными устройствами. Это может быть микрофонный или линейный вход, и они должны быть уже задействованы. Иными словами, физически всё уже должно быть подключено к звуковой карте. Далее ещё один раз Tab и в следующем списке также выбираем ваше аудиоустройство. В моём случае входом служит Mic in at front panel (Pink) (Realtek High Definition audio, а выходом - Динамики (Realtek High Definition Audio).

В следующем списке выбирается битность: 16 bit, 24 bit, а также частота дискретизации, обычно она составляет 44100 hz. Если у Вас внешняя usb или FireWire карта с поддержкой asio, то в списке audio system нужно выбрать именно asio. Также параметр битности и sampleRate можно поднять, так как это улучшит качество звука.

Если в вашем распоряжении есть MIDI-устройство, его нужно настроить, точнее, указать Reaper, что оно у нас имеется, и мы хотим его использовать.

Чтобы задействовать MIDI-устройство в Reaper, нужно зайти в меню Options/Preferences, клавишей Tab в дереве на вкладке Audio найти MIDI Devices, дойти до первого списка, где найти Ваше MIDI-устройство, притянуть к нему JAWS-курсор, кликнуть правой кнопкой и в контекстном меню выбрать Enable input. Это если у вашей MIDI-клавиатуры есть только клавиши, и нет колёс питча и модуляции, и других контроллеров. А если есть, то нужно отметить Enable input for control messages. После всех настроек, чтобы всё это сохранить, идём клавишей Tab до кнопки ok.

Первая запись

После того, как закрыли настройки, мы оказываемся в окне треков, и если нажимать курсоры вниз или вверх, JAWS нам будет говорить "no tracks found", что значит, треков не найдено. Чтобы начать что-либо записывать, нам нужно создать трек. Для этого нажимаем комбинацию клавиш Alt+Insert, вводим имя трека, например, golos1, лучше использовать латинскую раскладку и нажимаем Enter. Для того чтобы эта функция сработала, клавишу Insert нужно предварительно отвязать от программы экранного доступа через центр настроек JAWS. Тем самым мы создали трек, на который и будем сейчас записывать. Курсорами вниз вверх убеждаемся, что мы стоим на созданном треке, нажимаем точку с запятой в латинской раскладке, тем самым мы указываем программе, что записывать мы хотим именно на этот трек.

Теперь при нажатии "r" латинская и начнётся запись.

Если то, что записалось, нам нравится, я для остановки записи рекомендую нажимать Ctrl+Shift+Alt+Пробел, так как, если мы нажмём пробел, Reaper нас будет спрашивать сохранить или не сохранить записанное. Если пробел Вам привычнее, то в появившемся диалоге нажимаем кнопку Save All.

Также при записи можно нажать "r", при этом остановится запись, но не воспроизведение. Если мы записываем какую-нибудь песню или музыку и знаем её темп, нам может понадобиться метроном, который включается и выключается по клавише m,а темп проекта можно узнать, нажав Ctrl+Shift+T. А если хотим ввести свой, то просто нажимаем клавишу с буквой T и после ввода нужного темпа жмём Enter, или в диалоге кнопку "ok".

В итоге, мы возвращаемся в окно треков, где у нас есть созданный трек, на котором у нас появился первый клип, который в терминологии Reaper называется Item.

После записи нам нужно вернуться в начало проекта. Для этого можно нажимать клавиши Home, End или PageDown/PageUp. Программа экранного доступа будет говорить, на каком такте мы находимся.

Клавишами Home, End мы всегда попадаем на первую долю текущего, предыдущего или следующего такта, а при навигации клавишами PageUp/PageDown происходит переход к предыдущему/ следующему такту, но позиция сохраняется. Также, нажав "j" в появившемся диалоге, можно ввести номер такта, на который хотим перейти. Сочетание клавиш Alt+Home и Alt+End перемещают нас в начало и конец проекта.

Тонкую навигацию по файлу можно осуществлять стрелками влево/ вправо, при этом, если держать эти клавиши, то мы будем слышать аудио в замедленном темпе и тональности. Это может быть удобно в том случае, если нам нужно найти какое-то место. Например, Вы склеивайте интервью и хотите убрать паузу между словами.

Записанных клипов на треке у нас может быть много. Также у клипов могут быть свои дубли, которые в терминологии Reaper зовутся "тейки".

Перемещение по клипам трека осуществляется комбинацией Ctrl+стрелка влево/вправо. Находясь на клипе, мы можем быстро попасть в начало или конец клипа комбинациями Ctrl +Home и Ctrl+End.

Все горячие клавиши в программе Reaper контекстно-зависимые, то есть, например, если Вы нажатием Ctrl+стрелка вправо встали на клип, то комбинация Ctrl+C скопирует именно клип. А если мы стоим на треке, то, соответственно, трек.

Давайте мы попробуем разрезать наш записанный клип. Для

этого при помощи Ctrl+стрелка влевовправо встаём на клип и находим нужное место вышеописанными способами навигации по аудио. В моём случае, это запись интервью, и я стрелками, клавишами Home/ End и PageUp/PageDown ищу то место, где начинается разговор. Также хорошо выручает пауза - это комбинация Ctrl+Пробел, то есть, как только мы слышим начало разговора, нажимаем Ctrl+Пробел, и с этого места мы можем разрезать клип, так как если мы нажмём просто Пробел, чтобы остановить, текущая позиция курсора вернётся в начало записанного клипа. Когда нужное место найдено, на клавиатуре нажимаем "s", JAWS должен сказать "1 item addet", это значит 1 клип добавлен. Нажав "s", мы выполняем команду Split items at cursor, тоже самое мы могли сделать, стоя на клипе, через контекстное меню. В итоге, перемещаясь сочетанием Ctrl+стрелка влево/вправо, мы уже увидим два клипа и можем проводить над ними какие-то действия. Например, банально удалить один из клипов, нажав Del; вырезать сочетанием Ctrl+X и впоследствии вставить в другую позицию курсора, нажав Ctrl+V; скопировать привычным сочетанием Ctrl+C; дублировать клип сочетанием Ctrl+D.

Программа Reaper позволяет изменять тональность клипов. Делается это клавишами плюс/минус на калькуляторном блоке, а клавиша Insert возвращает тональность в исходную. А сочетание Alt+Ctrl+плюс/минус регулирует скорость клипа. Исходную скорость клипа можно вернуть, нажав Alt+Ctrl+Insert.

Ещё можно глобально настроить проект таким образом, что при изменении темпа будет меняться и скорость аудио клипа. Для этого открываем настройки проекта. Делается это сочетанием Alt+Enter. Встаём на вкладку Project Settings и клавишей Tab ищем пункт Timebase for items/envelopes/markers. По умолчанию там выбрано time, но если переключить эту радиокнопку в состояние Beats (position, length, rate), то при изменении темпа скорость аудио также будет меняться без потери тональности. Это может оказаться удобным, если, например, Вам нужно подобрать что-то быстрое на слух. Чтобы эти настройки были актуальны для всех новых проектов, нужно нажать кнопку Save as default project settings.

Продолжим изучать особенности клипов и треков. Находясь на клипе, клавиша Tab перемещает нас по элементам управления клипа. Мы можем:

  • изменить громкость клипа item volume;
  • изменить панораму клипа, смещая его в левый, по центру или в правый канал. Для этого служит параметр take pan;
  • заглушить клип, нажав mute.

После того как переключили кнопку или отрегулировали громкость или панораму стрелками вверх/вниз или Home/End, PageDown/PageUp, для закрытия диалога и возвращения к клипу нужно нажать Enter или escape, чтобы покинуть диалог, не внося изменений. То же самое касается и дорожек. Стоя на треке, клавишей Tab мы будем перемещаться по параметрам трека. Когда нажали Tab и попали в виртуальный режим треков или клипов, в обратном направлении можно двигаться клавишами Shift+Tab, но если нажать это сочетание клавиш, находясь на клипе или треке, мы перейдем к параметрам Master трека. Там тоже есть громкость, панорама, а также элементы управления, актуальные для трека.

Вставка аудио в проект

Очень часто нам может понадобиться добавить к записанным трекам уже существующие аудиофайлы: музыка, стихи, семплы тех или иных событий, шум дождя, ветер и т.д. В общем, всё, что угодно в форматах wav, mp3, vma. Для этого создаём новый трек комбинацией Alt+Insert, пишем его название и нажимаем Enter. Затем, если Вы используете JAWS, нам нужно отвязать клавишу Insert. Для этого, находясь в окне Reaper, нажимаем Insert+6. В открывшемся диалоге центр настроек JAWS в поле поиска пишем Insert, клавишей Tab идём до дерева, вертикальными курсорами находим пункт "Использовать Insert" на дополнительной клавиатуре и пробелом снимаем флажок и далее по диалогу нажимаем кнопку "ok". Теперь дополнительная клавиша Insert свободна, её и нажмём, при этом у нас открывается стандартный многим знакомый по таким программам, как Microsoft Word диалог, где нам необходимо найти наш аудиофайл.

Тот же самый диалог можно вызвать из меню Insert Media file.

В открытом диалоге, если мы, выделяя клавишей Shift, открываем несколько файлов, перед нами появляется диалог:

REAPER Options
Import files on separate tracks? (no will Insert all files on one track)

Если мы нажмём кнопку "да", то один из файлов у нас импортируется на созданный нами трек, а для последующих файлов будут созданы свои треки. Если мы нажмём "нет", то на созданный нами трек аудиофайлы упадут в виде клипов, причём в отличие от первого варианта располагаться они будут последовательно друг за другом.

Плавное повышение и понижение громкости в начале и конце клипа

Очень часто нам нужно сделать плавный подъём уровня в начале или обратное действие в конце клипа. Соответственно, в начале клипа громкость нужно плавно поднять, а в конце плавно убавить. К примеру, если нам нужно сделать плавное повышение громкости от начала до определённого места, то в той точке, до которой громкость должна восстановиться, достаточно нажать сочетание Ctrl+I.

Иными словами, команда fade items in to cursor устанавливает входной фейд от начала клипа до позиции курсора.

То же самое делается и с понижением громкости. Команда fade items out from cursor комбинация Ctrl+O плавно понижает громкость от текущей позиции курсора до конца клипа.

После того как мы проделали работу с материалом, необходимо сохранить проект, но об этом чуть позже, а сейчас научимся экспортировать проект в wav или mp3.

Экспорт аудио

Для того чтобы смикшировать все наши дорожки в 1 файл формата mp3, wav и многие другие, служит команда REnder, она находится в меню File. В первом списке REndering options Sample rate нам предлагается выбрать частоту дискретизации, которая по умолчанию составляет 44100. Далее по элементам диалогового окна двигаемся клавишей Tab.

Оставляем всё по умолчанию. Пока не будем вникать во все опции этого диалога, отмечу только некоторые из них. В поле output file показан путь, куда сохраниться наш файл. Кнопка output file brouze открывает диалог, где можно ввести имя нашего файла и выбрать папку, куда он будет сохраняться. Output file output format - тут мы выбираем, в каком формате будет наш файл, это может быть wav, AIFF, mp3, FLAC, OGG Vorbis и другие. В частности, при выборе, например, сохранения в mp3 в диалоге будут настройки режима mode и bit rate.

Чтобы была возможность сохранять в mp3, нам нужно скачать и положить в папку с программой файл lame_enc.dll, обычно при попытке сохранить в этот формат Riper сам предложит скачать этот файл, точнее, он отправит нас на нужную страницу, где соответственно битности операционной системы и нужно скачать необходимый файл. После того как положим файл, Reaper нужно перезагрузить. В портабельной версии, которую использую я, всё это уже проделано. В итоге, когда все необходимые настройки произведены, чтобы сохранить наши дорожки в один файл выбранного формата, нажимаем кнопку REnder и ждём окончания.

Сохранение проекта

Работать над одним проектом Reaper мы можем очень долгое время, значит нам нужно научиться его сохранять. Под проектом понимается совокупность аудио, MIDI-данных и служебной информации. Такой проект мы можем открыть только в программе Reaper. Для сохранения проекта можно закрыть программу или только проект меню File/Close project, и Reaper предложит его сохранить, или идём в меню File/Save project as,открывается стандартный диалог сохранения файлов, где нам нужно написать имя проекта и выбрать папку, но есть некоторые нюансы. При навигации по диалогу клавишей Tab фокус ввода не попадает в некоторые из настроек. Чтобы до них добраться, нужно переключиться на JAWS-курсор (клавиша минус на калькуляторном блоке при отключённом Num Lock), опуститься вниз окна (клавиша PageDown). Поднимаясь стрелкой вверх, мы обнаружим флажки, установить которые можно левой кнопкой мыши (клавиша слеш на калькуляторном блоке).

Рекомендую поставить следующее:

  • Create subdirectory for project создаёт отдельную папку для проекта.
  • Copy all media into project directory копирует все данные проекта, в том числе и сторонние импортированные файлы.
  • Move all media into project directory перемещает в папку проекта все использующиеся данные.

После того как всё настроили, необходимо нажать кнопку "Сохранить". Повторно открыть проект можно через меню File/Open project .

Работа с action (горячие клавиши)

Reaper предоставляет очень гибкие возможности по работе при помощи сочетаний клавиш. Есть возможность назначить горячие клавиши на те или иные действия или объединить несколько действий в одно. Для этого нам служит пункт Show action list из меню Action. Рассмотрим подробнее этот диалог.

Условимся, что все действия в Reaper мы будем называть action.

Далеко не все возможности программы есть в пунктах меню, некоторые из них и скрываются в этом диалоге. При открытии Action List мы, как правило, попадаем в фильтр, где можем написать имя экшена, который хотим найти.

Кнопка Run/Close запускает выделенный action в списке и закрывает диалог. Close просто закрывает диалог, но можно также нажать клавишу Escape.

Есть очень полезная кнопка Find shortcut, которая активирует диалог поиска по сочетаниям клавиш. В этом диалоге мы можем ввести нужную комбинацию и проверить, назначен ли на неё какой-нибудь action. Если сочетание назначено, в соответствующем списке будет показано действие - action. В списке Session мы выбираем категорию. Например, в категории Main перечислены основные экшены, а в MIDI Event List Editor отображаются все действия, связанные с редактированием MIDI. Далее в списке отображаются все экшены, например, если в поле фильтр написать recording и клавишей Tab дойти до этого списка, то там мы увидим все функции, связанные с записью, и если горячая клавиша назначена, то она будет располагаться перед названием действия. В следующем списке ShortCut for selection action отображается горячая клавиша действия или MIDI-событие, так как на все команды в Reaper можно назначить не только клавиатурную комбинацию, а также MIDI-событие, то есть это нам позволяет привязать управления командами с MIDI-устройства, например, MIDI-клавиатуры или контроллера. Кнопка Add открывает диалог добавления комбинации, где нужно нажать сочетание клавиш, ноту на MIDI-клавиатуре, или вращать фейдеры и регуляторы MIDI-устройства. Это может быть удобно, если, например, у Вас есть ножной MIDI-контроллер, подключённый к MIDI-клавиатуре или синтезатору. Вот на него можно назначить, например, action для начала записи или воспроизведения/ остановки.

Кнопка Delete short cut удаляет комбинацию, но её надо предварительно выделить в списке.

Кнопка New открывает диалог создания своего экшена. К примеру, мы можем собрать несколько экшенов в один и дать ему своё уникальное имя, тем самым какие-то часто исполняемые действия объединить. К примеру, на мой взгляд, удобно собрать в одно действие выделение всех клипов и команду Glue items, которая склеивает все выделенные клипы в один.

Кнопка Edit позволяет отредактировать выбранный action, в том числе и переименовать. Delete удаляет action, а Copy копирует. Это тоже понадобится при создании своих экшенов. Import/Export позволяет сохранить или импортировать свои настройки, или вернуть всё к настройкам по умолчанию.

Menu editor позволяет расширить стандартное меню своими командами. Туда мы можем поместить любой интересующий нас action, делать подменю, в общем, удобно всё это группировать. Описание того, что делают те или иные экшены, Вы сможете найти в подкастах Геннадия Зиновьева. Во втором подкасте есть некоторые пояснения в папке "Статейки".

Заключение

На этом я заканчиваю краткий обзор программы Reaper. В статье описаны лишь малые её возможности. Наряду с этим она позволяет создавать сложную маршрутизацию vst-эффектов реального времени, подключать синтезаторы и семплеры формата vst, dx и соединяться с другими программами по протоколу rewire.

Если у вас есть вопросы по программе Reaper или любой другой виртуальной студии, подписывайтесь на рассылку звучащая вселенная. Как это сделать, читайте на нашем сайте http://www.nativekeys.mostinfo.ru/. Также можно обратиться в нашу группу на vk.com.



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2017