Горячие главиши в среде разработки Borland C++ Builder

Источник:people.overclockers.ru
Дата публикации:2005
Twitter Facebook Vkontakte

В интегрированной среде разработки (IDE) Borland C++ Builder есть ряд возможностей, которые повышают удобство использования редактора и отладчика. Некоторые из них доступны как через пункты меню, так и с помощью горячих клавиш, однако многие доступны только с клавиатуры.

Я не буду описывать "известные" сочетания, такие, как Ctrl+C / Ctrl+V, которые работают в большинстве Windows-приложений. Кроме того, описанные ниже возможности - это не полный список, а только те функции, которые лично я применяю в своей работе.

Описанные ниже клавиатурные команды относятся к Borland C++ Builder 6, хотя некоторые из них могут работать и в более ранних версиях, также я использую вариант клавиатурных команд по-умолчанию (Tools - Editor Options - Key Mappings tab - Default), для других вариантов клавиатурные сокращения могут отличаться от приведенных.

Итак, приступаем.

1. Управление окнами редактора

Кратко:

  • F12 переключатель форма/модуль
  • Ctrl + F6 переключатель cpp/h файл
  • Ctrl+Enter открыть файл под курсором
  • Ctrl+Tab / Ctrl+Shift+Tab передвижение по закладкам редактора вперед / назад
  • Ctrl+F12 список модулей проекта
  • Alt+0 список открытых окон IDE

Подробно:

F12 - переключатель форма/модуль. Эта функция работает для модулей, которые связаны с dfm-формами. При нажатии F12 в режиме редактирования формы мы переключаемся на соответствующий cpp-файл и наоборот, находясь в режиме редактирования cpp- или h-файла с помощью F12 можно перейти к форме.

Ctrl + F6 - переключатель cpp/h файл. Для переключения между cpp и h файлом предназначена функция контекстного меню редактора "Open Source/Header file", клавиатурное сочетание для вызова этой функции - Ctrl + F6.

Другой удобной возможностью редактора является "связывание" cpp и h-файлов, когда они показываются в виде закладок в нижней части окна редактора, что позволяет сократить количество открытых в редакторе окон. Точно не помню, в какой версии BCB появилась эта возможность, по моему в пятой или в шестой, до этого все файлы отображались на закладках в верхней части редактора. Связь между файлами поддерживается за счет директивы #ifndef - #define в заголовочном файле, прямое назначение которой - не допускать повторных включений h-файла. Предположим, у нас есть файлы mainFile.cpp и mainFile.h. Эти файлы будут "связаны" друг с другом редактором (т.е. появятся на закладках в нижней части), если начало файла mainFile.h будет таким:

#ifndef mainFileH
#define mainFileH

Если заменить mainFileH на mainFile_HeaderH (или на что-либо другое), это никак не повлияет на основную функцию этого макроса - повторных включений этого заголовочного файла производится не будет. Однако это повлияет на вспомогательную функцию - связь между h и cpp файлом будет разорвана и закладки в нижней части редактора исчезнут.

Ctrl+Enter - открыть файл под курсором. Эта функция доступна также в контекстном меню редактора - "Open File at Cursor".

Ctrl+Tab / Ctrl+Shift+Tab - передвижение по закладкам редактора. Если в редакторе открыто несколько окон с исходными файлами, то можно перемещаться между окнами вперед с помощью Ctrl+Tab, а назад - с помощью Ctrl+Shift+Tab.

Ctrl+F12 - список модулей. При использовании данного сочетания выводится окно, содержащее список исходных файлов проекта. В верхней части этого окна есть строка, отображающее имя выбранного в текущий момент файла. Эта же строка может использоваться для поиска нужного файла - если начать набирать имя файла, то будет осуществляться инкрементальный поиск файла. И еще одна полезность - при открытии окна в нем автоматически выбирается текущий активный файл в редакторе.

Shift+F12 - список форм. При использовании данного сочетания клавиш открывается окно, содержащее список форм проекта. Работа с этим окном аналогична работе с описанным выше окном списка модулей.

Alt+0 - список открытых окон IDE. Обычно у меня на экране не хватает места, чтобы расположить на нем сразу все нужные окна IDE - это может быть редактор, инспектор объектов, окно TreeView, редактор формы и что-нибудь еще. Так как для редактора нужно больше пространства, то он имеет привычку накрывать собой другие, более мелкие окна. Чтобы найти "спрятанные" окна IDE можно воспользоваться сочетанием Alt+0, которое выводит окно со списком всех открытых окон.

2. Операции с выделенным текстом

Кратко:

  • Shift+arrow выделение обычного блока, в режиме выделения колонками - выделение блока-колонки
  • Alt+Shift+arrow выделение блока-колонки
  • Ctrl+O+C / Ctrl+O+K включить / выключить режим выделения колонками (колонки будут выделяться при использовании Shift+arrow)
  • Ctrl+K+I / Ctrl+K+U передвижение выделенного блока вперед / назад на одну позицию табуляции

Подробно:

Shift+arrow - это, в принципе, общеизвестное сочетание для выделения текста - при нажатом Shift, перемещение курсора стрелками вызывает выделение текста. Обычно тест выделяется построчно, но в режиме выделения колонками тест это сочетание позволяет выделять прямоугольные блоки.

Alt+Shift+arrow - выделение прямоугольного блока (или блока-колонки). Иногда выделение текста в виде прямоугольного блока может быть гораздо более удобным, чем построчное выделение. При копировании прямоугольного блока вставка происходит иначе, чем при копировании обычного блока - имея какой-то текст, можно вставить прямоугольный блок рядом с этим текстом, слева или справа. После выделения прямоугольного блока (с помощью Alt+Shift+arrow) происходит переключение в режим выделения колонок, выключить этот режим можно либо щелкнув мышью в любом месте редактора, либо нажав Ctrl+O+K.

Ctrl+O+C / Ctrl+O+K - включает / выключает режим выделения колонками. При включенном режиме выделения колонками, сочетание Shift+arrow будет выделять прямоугольные блоки. Кроме того комбинации Ctrl+O+C / Ctrl+O+K позволяют преобразовать уже выделенный блок из обычного в прямоугольный и обратно. Щелчек мыши в любом месте редактора отключает режим выделения колонками.

3. Инкрементальный поиск

Кратко:

  • Ctrl+E перейти в режим инкрементального поиска (F3 - искать дальше)
  • Alt+Ctrl+"Up arrow" / Alt+Ctrl+"Down arrow" перейти к предыдущему / следующему такому же слову в тексте

Подробно:

Ctrl+E - включает режим инкрементального поиска. После нажатия этого сочетания клавиш, в строке состояния редактора появляется приглашение "Searching for:". При последующем наборе текста, будет производится поиск этого текста в окне редактора. При вводе искомого текста можно использовать Backspace для удаления одного символа. После того, как искомая строка набрана, клавиша F3 позволяет найти эту строку дальше по тексту. Преимущество инкрементального поиска перед обычным - ускорение работы, так как он позволяет избежать отображения диалогового окна поиска (вызывается по Ctrl+F), недостаток - отсутствие дополнительных параметров поиска, которые есть в диалоге.

Alt+Ctrl+"Up arrow" / Alt+Ctrl+"Down arrow" - перейти к предыдущему / следующему такому же слову в тексте. В принципе, это сочетание - тоже довольно удобное средство поиска. Находясь на каком-либо слове, например имени функции, можно поискать в текущем файле вхождения данной функции - вверх по файлу Alt+Ctrl+"Up arrow", вниз по файлу - Alt+Ctrl+"Down arrow".

4. Режим отладки

Кратко:

  • Ctrl+F7 окно Evaluate/Modify - просмотр/копирование и изменение значения переменной
  • Al+Ctrl+W окно Watches
  • F8 пошаговое выполнение без заходов в функции
  • F7 пошаговое выполнение с заходами в функции
  • F4 выполнить до курсора
  • Shift+F8 выполнить текущую функцию до возврата
  • Ctrl+F2 прервать выполнение программы
  • F5 установить / убрать точку останова

Подробно:

Ctrl+F7 - открывает окно Evaluate/Modify - окно позволяет просмотреть/изменить значение переменной. Кроме того, можно скопировать значение, что удобно при просмотре тестовых свойств. Я, например, часто копирую значение Query->SQL->Text, чтобы выполнить запрос к базе данных из IBExpert.

Al+Ctrl+W - открывает окно Watches, если оно уже открыто, то оно выводится на передний план.

F8 - пошаговое выполнение без заходов в функции, доступно из меню Run - Step Over..

F7 - пошаговое выполнение с заходами в функции, доступно из меню Run - Trace Into.

F4 - выполнить до курсора, доступно из меню Run - Run to Cursor.

Shift+F8 - выполнить текущую функцию до возврата, и остановиться в точке возврата из функции. Доступно из меню Run - Run Until Return. Это сочетание особенно полезно, когда по F7 попадаешь не в ту функцию, вместо того чтобы проходить по ее содержимому, можно просто нажать Shift+F8.

Ctrl+F2 - прервать выполнение программы, доступно из меню Run - Program Reset.

F5 - установить / убрать точку останова. По поводу точек останова замечу, что у них есть расширенные свойства, такие как, например условие останова. Отобразить и настроить эти свойства можно либо щелкнув правой кнопкой мыши по уже установленной точке останова и выбрав "Breakpoint properties...", либо добавив точку останова через меню Run - Add Breakpoint - Source Breakpoint...".

5. Другие полезные сочетания

Кратко:

  • Alt+F7/Alt+F8 передвижение вверх / вниз по списку ошибок и предупреждений, выданных компилятором
  • Ctrl+"Up arrow"/Ctrl+"Down arrow" прокрутить текст в редакторе на строку вверх / вниз без перемещения курсора
  • Ctrl+Shift + (0..9) установить / убрать закладку 0..9
  • Ctrl + (0..9) перейти к закладке 0..9
  • Ctrl+Shift+Space отображение параметров функции
  • Ctrl+Space отображение методов объекта
  • Alt + [ / Alt + ] отображение парной открывающей / закрывающей скобки

Подробно:

Alt+F7 / Alt+F8 - передвижение вверх / вниз по списку ошибок и предупреждений, выданных компилятором. После редактирования исходного кода в большом объеме, обычно, по крайней мере у меня, список ошибок тоже бывает внушительным. Щелчок мыши по сообщению об ошибке вызывает переход к файлу и строке, где эта ошибка обнаружена, перейти к следующей ошибке без использования мыши можно с помощью комбинации Alt+F7, к предыдущей - с помощью Alt+F8.

Ctrl+"Up arrow"/Ctrl+"Down arrow" - прокрутить текст в редакторе на строку вверх / вниз без перемещения курсора. Это удобно, если несколько интересующих строк не отображаются на экране. При использовании этих комбинаций, курсор остается в той же строке, где он и был до прокрутки.

Ctrl+Shift + (0..9) - установить / убрать закладку 0..9. Закладки - это очень полезная возможность, которой я постоянно пользуюсь. Закладки нумеруются внутри каждого файла отдельно.

Ctrl + (0..9) - перейти к закладке 0..9. С помощью закладок можно пометить несколько мест внутри исходного файла и затем быстро находить эти места. Если делать то же самое без закладок, используя прокрутку, то процесс поиска нужных мест становится просто мучительным.

Ctrl+Shift+Space - отображение параметров функции. По-умолчанию, эта функция редактора включена - при наборе имени функции и следующей открывающей скобки выпадает список параметров этой функции. Однако, в большом проекте этот процесс так "тормозит", что я эту функцию обычно отключаю (убираю флажок Tools->Editor Options->Code Insight->Code Parameters). Для того, чтобы вручную отобразить параметры функции, я пользуюсь сочетанием Ctrl+Shift+Space.

Ctrl+Space - отображение методов объекта. Как и в случае отображения параметров функции, автоматическое отображение методов я отключаю (убираю флажок Tools->Editor Options->Code Insight->Code Completion). Для того, чтобы вручную отобразить методы и поля объекта, я пользуюсь сочетанием Ctrl+Space.

Alt + [ / Alt + ] - отображение парной открывающей / закрывающей скобки, работает и для скобок "(", ")" и для скобок "{", "}". Раскладка должна быть включена английская, курсор должен находиться перед скобкой.

6. Сводная таблица

Сводная таблица содержит все описанные выше сочетания клавиш. Ее можно напечатать и иметь под рукой на случай, если какое-то сочетание вылетело из головы. Это помогает быстрее запомнить все сочетания клавиш, применение которых может ускорить работу при написании исходных кодов и их отладке.

Управление окнами редактора:

  • F12 переключатель форма/модуль
  • Ctrl + F6 переключатель cpp/h файл
  • Ctrl+Enter открыть файл под курсором
  • Ctrl+Tab / Ctrl+Shift+Tab передвижение по закладкам редактора вперед / назад
  • Ctrl+F12 список модулей проекта
  • Alt+0 список открытых окон IDE

Операции с выделенным текстом:

  • Shift+arrow выделение обычного блока, в режиме выделения колонками - выделение блока-колонки
  • Alt+Shift+arrow выделение блока-колонки
  • Ctrl+O+C / Ctrl+O+K включить / выключить режим выделения колонками (колонки будут выделяться при использовании Shift+arrow)
  • Ctrl+K+I / Ctrl+K+U передвижение выделенного блока вперед / назад на одну позицию табуляции

Инкрементальный поиск:

  • Ctrl+E перейти в режим инкрементального поиска (F3 - искать дальше)
  • Alt+Ctrl+"Up arrow" / Alt+Ctrl+"Down arrow" перейти к предыдущему / следующему такому же слову в тексте

Режим отладки:

  • Ctrl+F7 окно Evaluate/Modify - просмотр/копирование и изменение значения переменной
  • Al+Ctrl+W окно Watches
  • F8 пошаговое выполнение без заходов в функции
  • F7 пошаговое выполнение с заходами в функции
  • F4 выполнить до курсора
  • Shift+F8 выполнить текущую функцию до возврата
  • Ctrl+F2 прервать выполнение программы
  • F5 установить / убрать точку останова

Другие полезные сочетания:

  • Alt+F7/Alt+F8 передвижение вверх / вниз по списку ошибок и предупреждений, выданных компилятором
  • Ctrl+"Up arrow"/Ctrl+"Down arrow" прокрутить текст в редакторе на строку вверх / вниз без перемещения курсора
  • Ctrl+Shift + (0..9) установить / убрать закладку 0..9
  • Ctrl + (0..9) перейти к закладке 0..9
  • Ctrl+Shift+Space отображение параметров функции
  • Ctrl+Space отображение методов объекта
  • Alt + [ / Alt + ] отображение парной открывающей / закрывающей скобки

7. О вышеизложенном

Если по поводу изложенного материала есть вопросы и замечания, то я готов их принять - пишите seb.goo@gmail.com .



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2017