Создание аудиокниг в формате DAISY с помощью программы Obi

Дата публикации:2011
Twitter Facebook Vkontakte

Программа Obi является самым мощным и удобным из бесплатных средств для создания аудиокниг в формате DAISY. Она позволяет конвертировать уже имеющиеся аудиокниги из форматов mp3 и wav в формат DAISY, а также создавать DAISY-книги, записывая звук с внешних источников: микрофон, аудиокассета и так далее. Программу можно использовать в библиотеках для слепых и студиях звукозаписи, для начитывания аудиокниг в формате DAISY с плоскопечатных оригиналов или оцифровки звуковых книг с кассет, компакт-дисков и так далее.

Установка и настройка программы

Загрузить программу и скрипты JAWS к ней можно со страницы загрузкиhttp://daisy.trac.cvsdude.com/obi/wiki/downloads. для работы программа использует платформы Net Framework и Java SE Runtime. входе установки программа выведет вопрос хотите ли вы установить компоненты JAVA. Если у вас на компьютере уже установлена платформаJava SE Runtime, то нажмите "Нет". если Java у вас не установлена, то нажмите "Да". в этом случае, программа запустит загрузку и установку компонент Java из Интернета.

после установки программы необходимо произвести первоначальные настройки. откройте программу. в появившемся диалоге с кнопками нажмите "Open Obi with no Project". откроется окно с пустым проектом. в меню "Tools" выберите "Preferences". на вкладке "Project" укажите диск или папку где программа будет создавать папки с проектами. если вы хотите, чтобы программа при запуске сразу открывала последний рабочий проект, то установите флажок "Open last project when starting Obi". на вкладке "Audio" выберите устройства воспроизведения и записи. рекомендую оставить значения "Первичный звуковой драйвер". в этом случае запись будет производиться с того устройства, которое выбрано в настройках записи диалога звуковых настроек Windows. в списке "Noise Level" выберите уровень шума в помещении где будет производиться запись с микрофона. Если у вас хорошо звукоизолированная студия, то можно поставить "Low". установите флажок "Audio Clues", чтобы программа использовала звуковые сигналы для различных событий, таких как начало и конец выделения аудиосодержимого. нажмите "Ok" и закройте программу. теперь можно переходить к созданию проекта DAISY-книги.

Создание проекта

откройте Obi. в первоначальном диалоге нажмите "Create a New Project". в поле "Title" впишите название вашей книги транслитом латинскими буквами. многие программные DAISY-плееры (в частности FSReader) не поддерживают кириллические названия книг. флажок "Automatically create a title section with this title" лучше снять, поскольку , когда он отмечен, в проекте автоматически появится пустой раздел с названием книги. этот флажок можно установить, если вы собираетесь записывать новую книгу с микрофона, или книга будет состоять только из одного раздела. нажмите "Ok" и откроется окно проекта.

Окно проекта состоит из дерева разделов и окна содержимого. переключаться между ними можно нажимая клавишу F6. кроме того, рядом с деревом разделов находятся панели с вертикальной и горизонтальной шкалой выделения аудиосодержимого и панель навигации с кнопками. переключаться между ними можно нажимая комбинации Control+Tab и Control+Shift+Tab. шкалы для выделения аудиосодержимого используются только при выделении мышью, при работе с клавиатуры они не нужны.

теперь вам нужно создать структуру разделов. называть разделы можно и русскими буквами. чтобы создать новый пустой раздел, в дереве разделов откройте контекстное меню и выберите "Add Section". введите название раздела и нажмите Enter. в этом же контекстном меню вы можете добавлять в разделы подразделы, объединять или разделять разделы, вставлять между разделами новый раздел и так далее. уже созданные разделы можно перемещать на более высокий или более низкий уровень. чтобы переместить раздел на один уровень вниз, стоя на разделе, нажмите Control+Shift+Стрелка вправо, чтобы переместить раздел на один уровень вверх, нажмите Control+Shift+Стрелка влево. разделы разных уровней удобно использовать, когда книга разделена на части, главы и параграфы. например, у вас имеется аудиокнига, в которой две части, каждая из которых разбита на главы и параграфы. тогда создаём два раздела первого уровня с названиями "Часть1" и "Часть 2". затем в каждом из этих разделов создаём подразделы с названиями "Глава 1", "Глава 2" и так далее. а в каждом разделе второго уровня для главы создаём подразделы с названиями параграфов. получаем три уровня разделов.

Разделы можно перемещать вверх и вниз по списку, используя стандартные команды вырезания и вставки. на том разделе, который мы хотим переместить, нажимаем Control+X, затем встаём на тот раздел, после которого мы хотим вставить вырезанный раздел, и нажимаем Control+V. когда дерево разделов полностью создано, можно переходить к заполнению проекта аудиосодержимым.

Импорт аудиофайлов в книгу

для примера будем считать, что у нас имеется папка с аудиокнигой в виде набора файлов формата mp3. книга разделена на главы и к каждой главе относятся несколько mp3 файлов. создаём в дереве разделов разделы для каждой главы, встаём на раздел "Глава 1" и нажимаем F6. попадаем в пустое окно аудиосодержимого. теперь нам нужно заполнить его аудиофайлами. нажимаем Control+I, или выбираем "Import Audio Files" в меню "Phrase". находим и выделяем на диске все файлы относящиеся к первой главе, и нажимаем "Открыть". программа зависнет на некоторое время, поскольку она преобразует файлы в обычный звук формата wav. дождитесь окончания и появления диалога импорта. снимите флажок "Create section for each phrase", а флажок "Split phrases on import" оставьте отмеченным. при импорте Obi разделит все файлы на короткие звуковые фрагменты, называемые фразами. длину фраз в минутах вы можете указать в поле рядом. многие DAISY-плееры поддерживают перемещение не только по разделам, но и по фразам. так что эта функция - очень полезна. нажмите "Ok" и дождитесь окончания импорта. вернитесь в дерево разделов, нажав F6, выберите следующий раздел "Глава2", снова нажмите F6, для перехода в окно аудиосодержимого, и повторите операцию импорта файлов уже для второй главы. повторяйте эту операцию для всех разделов с главами, пока не заполните все разделы соответствующими аудиофайлами.

если в вашей mp3 книге каждая глава состоит только из одного файла, то лучше поступить так: создайте в дереве разделов один пустой раздел, при импорте файлов выберите все файлы в книге и установите флажок "Create section for each phrase". в этом случае, Obi для каждого файла создаст раздел с тем же названием, что и файл. после импорта удалите пустой раздел и правильно рассортируйте автоматически созданные разделы и переименуйте их как вам нужно.

Если ваша книга состоит только из одного файла, то создайте в дереве разделов один раздел и импортируйте в него этот файл. вы получите книгу разбитую на фразы указанной длины. по умолчанию 10 минут. однако, вы можете автоматически разбить файл на более логично устроенные фразы. для этого, находясь в окне аудиосодержимого, сделайте следующее:

  1. перейдите на первую фразу в книге.
  2. нажмите Control+Shift+E, чтобы отметить эту фразу как фразу с тишиной.
  3. нажмите Control+K, чтобы снять автоматически присваиваемый таким фразам тип не используемых.
  4. перейдите к следующей фразе, нажав Стрелку вправо.
  5. нажмите Control+Shift+P.

Obi попытается определить уровень тишины в начальной фразе. если обнаружить тишину удалось, то программа выведет сообщение с значениями уровня и длины сигнала распознанного как тишина. нажмите "Ok", чтобы начать разбиение на фразы в соответствии с этими значениями. если обнаружить тишину не удалось, то Obi выведет диалог с сообщением о том, что найти фрагмент тишины ей не удалось и вы должны настроить уровень тишины вручную. нажмите "Ok", откроется диалог настроек пауз. здесь вы можете указать уровень сигнала, который считается тишиной, длину звукового отрезка в течении которого должен наблюдаться такой уровень и так далее. после окончания настроек, нажмите "Ok" и Obi создаст новые точки разбиения на фразы в тех местах, где она обнаружила подходящий по силе и продолжительности сигнал. так можно получить фразы, начинающиеся с начала новой главы или части. затем в этих точках можно создать начало нового раздела.

Разметка и редактирование аудио

после импорта всех аудиофайлов и создания фраз вы можете отредактировать аудио, убрав ненужные фрагменты записи или разделив запись на более мелкие фрагменты. нажатие клавиши Пробел начинает воспроизведение текущей фразы. при этом курсор редактирования движется вслед за воспроизведением. нажав Пробел снова, вы останавливаете воспроизведение и курсор редактирования в точке остановки. здесь вы можете открыть контекстное меню и выбрать нужную команду редактирования. например, если вы хотите создать в этой точке начало нового раздела, то в контекстном меню выберите "Insert Section". в дереве разделов появится новый раздел, начинающийся именно с этого места. чтобы остановить воспроизведение и вернуть курсор редактирования в начало фразы, нажмите Control+Пробел. для перехода к следующей или предыдущей фразе нажимайте Стрелку вправо и Стрелку влево соответственно. для перехода в начало первой фразы в текущем разделе нажмите Home, для перехода в начало последней фразы в текущем разделе нажмите End. для перехода в начало первой секции в книге нажмите Control+Home, а для перехода к последней секции в книге нажмите Control+End. для перехода в начало следующей секции нажмите Control+Shift+Стрелка вниз, а для перехода в начало предыдущей секции нажмите Control+Shift+Стрелка вверх. если воспроизведение остановилось при нажатии этих комбинаций, просто нажмите Пробел для начала воспроизведения с выбранной точки.

если вы остановили курсор редактирования в некоторой точке книги, и хотите сдвинуть его на малую величину вперёд или назад, то используйте команду N, для сдвига курсора вперёд, и Shift+N, для сдвига курсора назад. величина сдвига при одном нажатии задаётся значением в миллисекундах в поле "Nudge Interval" в диалоге "Preferences" на вкладке "Audio". чтобы прослушать небольшой фрагмент от позиции курсора редактирования, нажмите V, а чтобы прослушать небольшой фрагмент до позиции курсора, нажмите X. быструю перемотку вперёд и назад выполняют команды Control+Точка (английская раскладка) и Control+Запятая (английская раскладка) соответственно.

если вы хотите выделить какой-либо фрагмент аудиосодержимого, чтобы, например, удалить его из книги, то сделайте следующее:

  1. нажмите Пробел для начала воспроизведения и движения курсора редактирования.
  2. в месте, с которого вы хотите начать выделение, снова нажмите Пробел, для остановки курсора в текущей точке.
  3. нажмите Control+[ для начала выделения.
  4. снова нажмите Пробел. начнётся воспроизведение, при этом всё воспроизводимое содержимое будет выделяться.
  5. в той точке, где вы хотите закончить выделение, снова нажмите Пробел. воспроизведение остановится.
  6. нажмите Control+] для окончания выделения. после этого содержимое от точки начала выделения до точки окончания выделения окажется выделенным, и вы можете удалить или скопировать его. чтобы прослушать выделенный фрагмент, нажмите C.

Запись аудио в книгу

если вы хотите записать, например, плоскопечатную книгу с микрофона или оцифровать книгу с аудиокассеты, то вы можете записать звук прямо в ваш проект книги. сначала в дереве разделов создайте пустой раздел с названием книги. нажмите F6 для перехода в окно аудиосодержимого. нажмите Control+Shift+R -начнётся запись. для остановки записи нажмите Пробел. Obi создаст новую фразу, содержащую записанный звук. если вы снова нажмёте Control+Shift+R, то начнётся запись новой фразы и так далее. если вы хотите, чтобы Obi не начала новую фразу, а перезаписала последнюю фразу, то, вместо Пробел, для остановки записи нажмите Control+Пробел.

если вы можете наблюдать уровни сигнала при записи на экране, то можно начинать запись другим способом. нажмите Control+R и начните читать текст в микрофон. монитор сигнала отобразит уровни. если сигнал не зашкаливает, то снова нажмите Control+R и Obi начнёт запись.

в студиях звукозаписи аудиокниг, где имеются диктор, читающий текст, и звукоинженер, управляющий процессом записи, часто бывает удобно размечать записываемую книгу по фразам и разделам прямо в процессе записи голоса. Сначала создайте в дереве разделов структуру разделов и подразделов. затем перейдите в первый раздел, нажмите F6 для перехода в окно аудиосодержимого и начните запись. в ходе записи используйте следующие быстрые клавиши для разметки аудио:

чтобы начать новую фразу, нажмите K, чтобы запись продолжилась в следующий раздел, нажмите H, чтобы отметить в текущем месте записи начало новой страницы (если при чтении диктор объявляет номера страниц) нажмите P.

Сохранение DAISY-книги

после того, как вы полностью закончили разметку и редактирование вашего проекта, нужно сохранить его в формате DAISY-книги. для этого нажмите Control+E, или выберите "Export as Daisy" в меню "Tools". по умолчанию книга сохраняется в формате DAISY 3.0, но если вы собираетесь слушать книгу на старом аппаратном DAISY-плеере, который не поддерживает этот формат, то выберите DAISY 2.0. укажите папку, в которую следует сохранить все файлы DAISY-книги. в списке "Create One Audio File per Section for Level till" выберите уровень до которого все файлы более низких уровней будут объединены в один аудиофайл. DAISY-книга будет создана в выбранной папке.

однако, это ещё не всё. по умолчанию аудиофайлы в сохранённой DAISY-книге сохраняются в формате wav, и их нужно сжать в формат mp3. для этого, в меню "Tools" выберите "Convert Audio to Mp3". укажите нужный формат DAISY и нажмите "Ok". в открывшемся диалоге укажите путь к файлу с расширением .opf, который находится в папке с вашей сохранённой книгой, и папку, в которую следует сохранить сконвертированную в mp3 DAISY-книгу. после нажатия "Ok" начнётся конвертация и вы получите окончательный вариант DAISY-книги, пригодный для прослушивания на DAISY-плеерах.

если перед сохранением вы хотите изменить в метаданных книги имя создателя книги или имя диктора, то нажмите Control+Alt+M в окне проекта, чтобы открыть панель метаданных. в списке полей найдите поля DC:Creator для имени создателя книги, и DTB:Narrator для имени диктора, впишите отличные от вписанных по умолчанию значения в редакторы рядом с названиями полей, и нажмите кнопку "Update". например, в качестве имени создателя книги вы можете указать название студии или библиотеки. эта информация отображается в названии книги в DAISY-плеерах. снова нажмите Control+Alt+M, чтобы закрыть панель.

Перенос и открытие книги

чтобы посмотреть, что у вас получилось, вы можете открыть и послушать созданную вами DAISY-книгу в программном DAISY-плеере FSReader, который устанавливается вместе с JAWS. в окне FSReader нажмите Control+O, укажите диск или папку где находится папка с созданной книгой и нажмите "Открыть". должно появиться дерево разделов и название книги. если вас всё устраивает, то можете скопировать вашу DAISY-книгу на карту памяти вашего DAISY-плеера (например, PlexTalk), слушать её и перемещаться в книге по разделам, страницам и фразам.



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2017