Начало работы с брайлевским транслятором Duxbury

Дата публикации:03.05.2022
Поделиться в Twitter Поделиться в F******k Поделиться в VKontakte Поделиться в Telegram

Вместо предисловия

Брайлевский транслятор Duxbury (Duxbury Braille Translator) — это программа для преобразования электронных документов, содержащих плоскопечатный текст и изображения, в рельефно-точечный текст и рельефные контурные изображения для последующей печати на брайлевском принтере. Программа работает в операционных системах Microsoft Windows и Mac, имеет доступный графический пользовательский интерфейс, содержит встроенный редактор текста, позволяющий редактировать и плоскопечатный текст, и результат трансляции. Поддерживается импорт документов в форматах Microsoft Word и Open Office, поиск и выявление грамматических ошибок, имеются широкие возможности по форматированию плоскопечатного и рельефно-точечного текста. Программа русифицирована.

За основу для настоящей статьи взята официальная документация на английском языке. Все приводимые примеры проверены. На борту — MS Windows 8.1, NVDA и брайлевский транслятор Duxbury 12.3. Материал излагается в простой форме по принципу «делай как я». И да, автор не претендует на полноту, безошибочность и художественную выразительность своего текста, который предоставляется на условиях «как есть». Однако автору хотелось бы, чтобы материалы были для незрячих доступны в той или иной форме. В данном случае в письменной.

Создание нового документа

  1. Выберите меню Файл -> пункт Создать... Или же воспользуйтесь горячими клавишами (Control + N. Сначала нажмите клавишу Control, а затем, не отпуская уже нажатую, нажмите клавишу N.
  2. Выберите в появившемся диалоговом окне радиокнопку «Тип документа: Плоскопечатный», а также предпочитаемый шаблон из списка «Шаблон документа». Для этого упражнения не имеет значение, какой шаблон документа будет выбран.
  3. Подтвердите выбор нажатием кнопки OK.

Обратите внимание: горячие клавиши указываются рядом с соответствующим названием пункта меню. Например, вы можете нажать горячую клавишу Control + N и это будет быстрее чем выбрать Файл -> Создать... Горячие клавиши — это лёгкий и быстрый способ выполнить команду.

Ввод нового текста

В качестве нашего первого документа наберём простое письмо. Вводите следующий текст, используя двойное нажатие клавиши Enter для каждой пропускаемой строки. Не нажимайте клавишу Enter там, где заканчивается строка в пределах абзаца. Просто пользуйтесь клавишей Пробел обычным образом, как если бы нужно было поставить пробел между словами. Пусть брайлевский транслятор автоматически переносит строки.

Дорогая мама,<Enter> <Enter>
Как ты? У меня всё хорошо. Я вожусь с брайлевским транслятором компании Duxbury. Это не очень трудно!<Enter> <Enter>
Всё, что мне нужно, это — набрать текст, Сказать программе "перевести" и пустить на печать через брайлевский принтер.<Enter> <Enter>
С любовью,<Enter> <Enter>
Марина.<Enter> <Enter>

Вот и всё. Набирать текст так просто!

Далее мы обсудим, Что потребуется для качественного форматирования текста помимо двойного нажатия клавиши Enter для пропуска строк. Но в нашем случае это — всё, что нужно знать.

Трансляция документа

Выберите меню Файл -> пункт Преобразовать. Или же воспользуйтесь горячими клавишами Control + T. Всё! Документ преобразован.

Печать документа

Напечатать документ очень легко, а вот настроить брайлевский принтер может оказаться трудно. Сейчас предполагается, что оборудование у вас уже установлено и настроено.

Пожалуйста, убедитесь, что принтер корректно настроен, перед тем как пустить документ на печать. Если вы ещё не настроили принтер, то у вас не получится воспользоваться командой Файл -> Печать по брайлю... Ну, если всё с принтером в порядке, тогда:

  1. Выберите меню Файл -> пункт Печать по брайлю... Или же воспользуйтесь горячими клавишами Control+E.
  2. Подтвердите выбор нажатием кнопки OK. Или же просто нажмите клавишу Enter.

Закрытие документа

Есть три способа закрыть документ. Именно документ, а не приложение.

Длинный путь:

  1. Выберите меню Файл -> пункт Закрыть.
  2. Если транслятор спросит вас, хотите ли вы сохранить документ, нажмите кнопку «Нет».

С помощью мыши:

  1. Щёлкните по кнопке «Закрыть» в Окне документа.
  2. Если транслятор спросит вас, хотите ли вы сохранить документ, нажмите кнопку «Нет».

С помощью горячих клавиш:

  1. Воспользуйтесь горячими клавишами Control + F4.
  2. Если транслятор спросит вас, хотите ли вы сохранить документ, нажмите кнопку «Нет».

Сохранение документа

  1. 1. Выберите меню Файл -> пункт Сохранить. Или же воспользуйтесь горячими клавишами Control + S.
  2. Наберите в текстовом поле "letter.dxp" (без кавычек). Расширение .dxp указывает транслятору , что файл создается для плоскопечатного документа.
  3. Убедитесь, что файл сохраняется в папку с разрешениями на запись.
  4. Нажмите кнопку «Да». Или же воспользуйтесь клавишей Enter.

Примечание. При завершении работы транслятора также закрывается открытый документ.

Если вы внесли изменения в документ и еще не сохранили эти изменения, транслятор спросит вас, хотите ли вы сохранить изменения в документе.

Транслятор сохраняет положение курсора в документе. Если документ большой, то при следующем открытии документа вы, возможно, не увидите начало документа. Чтобы всё-таки увидеть начало документа при его следующем открытии, просто воспользуйтесь горячими клавишами Control + Home для перемещения курсора в самое начало этого документа перед сохранением. Если всё-таки вам нужно начать с того места, где вы остановились, тогда не следует перемещать курсор к началу документа перед сохранением.

Завершение работы транслятора

Длинный путь: Выберите меню Файл -> пункт Выход.

С помощью мыши: Щёлкните по кнопке «Закрыть» в Окне приложения.

С помощью горячих клавиш: Воспользуйтесь сочетанием клавиш Alt + F4.

@@@

Форматирование документа

Документы транслятора

Каждый раз, когда вы транслируете документ (преобразовываете в брайлевский документ), вы создаёте новый документ.

Очень важно: не транслируйте документ из плоскопечатного в брайлевский, а потом обратно в плоскопечатный и так далее. Таким образом вы получите много печатно-брайлевских документов. И в конце концов это может привести к путанице.

Если вы считаете, что нужно оттранслировать изменения плоскопечатного документа, лучше будет закрыть первый созданный вами брайлевский документ. Затем внести изменения в плоскопечатный документ, а уж потом уже снова оттранслировать изменённый плоскопечатный документ.

Следует придерживаться правила, что одновременно должны быть открыты либо один плоскопечатный документ, либо — один плоскопечатный и один брайлевский. Проверяйте наличие дополнительно открытых документов в меню «Вид».

Стили транслятора

Транслятор функционирует таким образом, чтобы плоскопечатный и брайлевский документы поддерживали соответствующие стили форматирования.

Если вы правильно пользуетесь стилями форматирования в плоскопечатном документе, вы заметите, что брайлевский документ будет также корректно отформатирован.

Хорошей иллюстрацией может послужить документ письмо матери, который мы написали ранее. Давайте изучим результат трансляции брайлевского документа.

Содержимое документа letter.brf:

DOROGA$ MAMA1
KAK T!5 U MEN$ WS* HORO:O4 $
WOJUS) S BRA&LEWSKIM TRANSL$-
TOROM .DUXBURY4 [TO NE OQEN)
TRUDNO6
WS*1QTO MNE NUJNO1[TO- NABRAT)
TEKST1SKAZAT) PROGRAMME 8PERE-
WESTI0 I PUSTIT) NA PEQAT) QE-
REZ BRA&LEWSKI& PRINTER4
S L\BOW)\1
MARINA4

Конец содержимого файла.

В брайлевском документе, как и ожидалось, есть пустые строки между абзацами. В нашем случае это четыре пустые строки и одна пятая пустая строка в конце.

Первая строка абзаца не имеет отступа. Это корректное форматирование для большинства плоскопечатных документов. Однако для брайлевских документов это форматирование некорректно.

Следует также обратить внимание, что переносы автоматически расставлены в брайлевском документе.

  1. Закройте брайлевский документ. И убедитесь, что плоскопечатный документ открыт. В нашем случае это файл letter.dxp.
  2. Откройте меню Вид, и если пункт Ключи не отмечен, то отметьте, выбрав его. Или же воспользуйтесь горячими клавишами Alt + F3. Таким образом вы можете переключаться между просмотром форматирования и просмотром ключей.

Обратите внимание: в конце каждого абзаца находится знак "меньше" заключенный в квадратные скобки.

Этот знак показывает, что здесь выполнен "жёсткий" переход на новую строку, другими словами, здесь нажата клавиша Enter. Таким образом транслятор создаёт новую строку. Таким способом новый абзац не создаётся, а всего лишь создаётся новая строка.

Стиль — это набор ключей.

[<]

«Жёсткий переход на новую строку » — это один из примеров таких ключей.

Есть ключи, которые выполняют пропуск строки ( [sl]), выравнивание текста по центру, трансляцию в компьютерный брайль и так далее.

Стили облегчают процесс форматирования текста. Вместо того чтобы вводить каждый из этих ключей вручную в начале и конце текста, лучше воспользоваться стилями, которые группируют эти ключи и вводят их за вас там, где нужно.

Существуют два типа стилей: символьные и абзацные. Также их называют гнездовыми и линейными (строковыми) стилями.

Абзацные стили применяются для всего абзаца. Примерами абзацных стилей являются «отступ», «пропуск строки перед абзацем» и так далее.

Символьные стили применяются только к выделяемым вами символам. Примерами символьных стилей вне брайлевского транслятора могут служить такие стили как курсив, полужирный, подчёркнутый. Их можно встретить в приложении Microsoft Word и в других текстовых процессорах.

В трансляторе эти стили, главным образом, служат для модификации вида плоскопечатного документа при преобразовании в брайль. Стили не всегда служат для визуализации текста в плоскопечатном документе.

Вот некоторые часто используемые стили. Посмотрим из назначение:

  • "compinline" Используйте этот символьный стиль для корректной трансляции e-mail и web-адресов.
  • "h1." Используйте этот стиль для больших заголовков таких как названия глав. "h1." соответствует стилю "заголовок уровень 1" в Microsoft Word. Этот стиль выравнивает по центру строку.
  • "h2." Используйте этот стиль для малых заголовков, таких как названия подзаголовков. "h2." соответствует стилю "заголовок уровень 2" в Microsoft Word. Благодаря этому заголовку строка располагается на пятой ячейке с последующей строкой-заполнителем на пятой ячейке.
  • "list." Используйте этот стиль для одноуровневого списка.
  • "note." Этот абзацный стиль используется брайлевскими редакторами-переводчиками для указания примечаний. С помощью этого стиля делается отступ абзаца до седьмой ячейки.
  • "outline." Многоуровневый список. Используйте этот стиль для формирования, к примеру, содержания или таблицы с подзаголовками. для входа на внутренний и выхода на внешний уровень воспользуйтесь горячими клавишами Alt + стрелка вправо и Alt + стрелка влево.
  • "para." Стиль обычного абзаца.

Упражнение: набор текста с корректным форматированием абзацев

При создании простого документа, такого как письмо, важно пользоваться стилями. Даже если плоскопечатный текст выглядит неплохо без использования стилей, всё равно при трансляции брайлевский документ не будет отформатирован соответствующим образом.

На этот раз при форматировании текста поступим следующим образом:

  1. Закройте документ letter.dxp.
  2. Создайте новый документ.
  3. Убедитесь, что активен режим просмотра форматирования, а не режим просмотра ключей. Вы можете проверить это, открыв меню «Вид». Проверьте, не отмечен ли пункт меню «Ключи». Если он отмечен, значит, активен режим просмотра ключей, иначе — режим просмотра форматирования. Для переключения режима воспользуйтесь горячими клавишами Alt + F3.
  4. Примените стиль "para." к документу для формирования обычного абзаца. Воспользуйтесь горячей клавишей F8. Или же выберите меню Верстка -> пункт Применить стиль... Далее найдите в списке «para.» и подтвердите выбор либо нажатием кнопки OK, либо клавишей Enter.
  5. для создания нового абзаца, вместо нажатия клавиши Enter, пользуйтесь горячими клавишами Control + M.

А вот пример документа:

Восемьдесят семь лет назад наши отцы породили на этом континенте новую нацию, воспитанную в духе свободы.<Control+M>
Они посвятили свою жизнь идее, что все люди созданы равными друг другу.<Control+M>
А теперь мы втянуты в великую гражданскую войну, которая, словно, проверяет наши идеалы на прочность.<Control+M>

Теперь переключитесь в режим просмотра ключей и посмотрите, какие ключи появились. Да, в NVDA нужно воспользоваться режимом объектной навигации, если вы совсем уж плохо слышите и хотите по символам нащупать каждый ключ. Можно просто двигаться вертикальными стрелками и слушать названия ключей.

Ключи брайлевского транслятора

Вы, скорее всего, поймёте, на сколько бывает важно переключаться между режимами просмотра форматирования и просмотра ключей. Помните, как переключаться между этими режимами быстро? Нет? Не помните? Воспользуйтесь горячими клавишами Alt + F3 и дело в шляпе.

Ну так вот! Нам пора воспользоваться этим режимом. Переключившись в режим просмотра ключей, мы увидим эти загадочные символы в квадратных скобках. Да-да — это и есть наши ключи. Забавно, но тут ничего нет сложного, обычный текст, просто курсором его нам пока не достать. Но не будем торопиться. Прочтём, что нам предложит создатель этого продукта.

Вставка ключа вручную

Ну вот, мы переключились в этот режим и, возможно, увидим нам знакомый ключ:

[<]

Это — ключ, и он нам знаком — «жёсткий переход на новую строку».

[sk1]

ключ «пропуск строки», но с параметром или аргументом, который предписывает пропустить одну строку.

А теперь внимание! Чтобы вручную вставить клю, поместите курсор в ту область текста, куда вы хотите вставить ключ, и нажмите горячую клавишу F9. Выскочит диалоговое окошко, в котором нам предложат ввести ключ и параметр. Окошко простое, там всего лишь поле редактирования и две волшебные (всем известные) кнопки.

Стыдно их упоминать. Вы не промахнётесь. Для примера просто введем именно так без квадратных скобок:

sk1

Ну, хочется надеяться, что далее понятно, что нужно подтвердить ваш выбор. И вы увидите, что ваш ключ вставлен. Но не так всё просто! Вы вертикальными стрелками это заметите, Но встать на него горизонтальными стрелками не получится. Ой, я ошибся, получится встать на левую квадратную скобку, но не более. Но это не страшно. Когда вы переключитесь обратно в режим просмотра форматирования, вы заметите лишнюю пустую строчку. Разумеется, что при трансляции это качество (пропуск одной строки) отразится и на брайлевском документе.

Кстати, если вы живете в английской раскладке клавиатуры, вы также можете нажать горячие клавиши Control + [ вместо вышеупомянутой. Руки зачесались и пришлось проверить, а не врёт ли документация.

Нажимаю Control +[, и вуаля! Появляется этот же диалог, но на этот раз ввожу:

sk3

Да-да! Хочу три пропущенных строки. Затем транслирую плоскопечатный документ нажатием Control + T, но это ничего не даёт. Сохраняю в .brf файл и считаю. действительно — три пропущенные строки, что и требовалось доказать самому себе.

Исправление ключа

Чтобы изменить один ключ на другой, нужно стать курсором на этот ключ. Да, это возможно. Помните, выше я писал, что ошибся. Нет, разработчики программы учли этот момент, поэтому и получается горизонтальными стрелками встать на левую квадратную скобку.

Поступаем так, чтобы заменить этот ключ на другой:

  1. Переходим в режим просмотра ключей.
  2. стрелками устанавливаем курсор на левую квадратную скобку. Повторю, это возможно.
  3. Выделяем, это один символ.
    Для тех, кто в танке! Нажимаем клавишу Shift и один раз жмём стрелку вправо.
  4. И ни-ни! Ни в коем случае не задеваем локтем другие клавиши! Иначе выделение пропадёт. И придётся повторить второй и третий шаги. Далее вызываем диалог либо F9, либо Control + [.
  5. В поле редактирования как раз и появится этот символ, который был выделен, сотрите его и впишите другой.
  6. Ну и подтвердите или отмените выполняемое действие.

А теперь поиграемся с этим навыком! Открываем программу и пишем:

Привет, дорогой друг!<Enter>
Как твои дела?<Enter>
Спишемся потом!

Переключим режим на просмотр ключей и получим следующую картину:

Привет, дорогой друг![<]
Как твои дела?[<]
Спишемся потом!

В режиме просмотра ключей в тексте появляются два одинаковых символа: [<] «жесткий переход на новую строку». Это мы в этом месте нажимали клавишу Enter.

Находим первый символ и выделяем его, стоя на левой квадратной строке. Программа NVDA будет молчать как рыба. Но нам-то нужно всего лишь один раз нажать Shift + стрелка вправо и при этом не задеть соседние клавиши. Нажимаем заветную горячку F9! или же Control + [.

Если всё было правильно сделано, то в поле редактирования появится и даже будет выделен символ < (меньше) без квадратных скобок. Теперь можно заменить этот символ на другой. А заменим мы его на p «новый абзац».

Вписываем символ p в поле редактирования и подтверждаем действие. Никаких квадратных скобок!

Проделываем то же самое со вторым символом и получаем такую картину:

Привет, дорогой друг!
[p]Как твои дела?
[p]Спишемся потом!

Обратите внимание, что эти символы появились в начале строки, так ведь логично, это же обозначения нового абзаца. Кстати, новый абзац при наборе текста ставится горячими клавишами Control + M.

Чтобы удалить ненужный или ошибочный ключ, достаточно навести стрелки на левую квадратную скобку и нажать Delete. Но помните, если это новая строка или же абзац, то строки соединятся в одну. И не только это может произойти. Всё зависит от назначения ключа.

Замена сразу всех одинаковых ключей и стилей

Возьмём снова текст:

Привет, дорогой друг![<]
Как твои дела?[<]
Спишемся потом!

Или же просто нажимая горячие клавиши Control + Z, Последовательно отменяем все предыдущие действия и проверяем состояние редактирования.

Давайте заменим два ключа «жесткий переход на новую строку» на два ключа «новый абзац».

Ой, чуть не забыл упомянуть, что стили записываются в угловых скобках <...>. Они также видны как и ключи в режиме просмотра ключей. Да... тафтология вышла... Но не суть.

Не будем отвлекаться.

Для замены всех одинаковых ключей:

  1. Выбираем меню Правка -> пункт Заменить... Или же жмём горячую клавишу F6.
  2. В поле «Найти») нажимаем горячку F9 или же Control + [. Как только вы это сделаете, появятся квадратные скобки и курсор окажется между ними. Впишите знак < (меньше).
  3. Нажмите клавишу Tab, чтобы перейти к полю редактирования «Заменить на:». В это поле впишите символ p, предварительно нажав горячие клавиши для ввода ключа.
  4. Далее протабулируйте до кнопки OK И нажмите на неё. Появится подтверждающее окошко, в котором нужно нажать «Всё». Ведь мы хотим заменить все ключи.

Таким образом мы можем заменять все одинаковые ключи.

Стили также могут заменяться, но вместо горячих клавиш для ввода ключей нужно воспользоваться горячими клавишами для ввода стилей — Control + Shift + <.

Другие элементы управления не должны вызывать затруднений, поэтому не будем тратить на них время.

Навигация по ключам с помощью NVDA

Руководство пользователя duxbury обошло вниманием мою любимую программу экранного доступа. В руководстве описывается, как можно «челюстями» перемещаться по ключам. Но судя по описанию, это тоже самое, что воспользоваться в NVDA режимом просмотра экрана или же, что еще лучше, пользоваться объектной навигацией. Просто выполняем Переход на объект в фокусе в настольной раскладке NVDA + numpadMinus, А в раскладке для ноутбука — NVDA + Backspace.

Далее проще паренной репы, ходим по символам или словам (вы должны это уже уметь делать). И считываем ключи или названия стилей. Можете даже скопировать текст.

Где-то в закромах интернета можно найти скрипты для «челюстей», если это только для таких нужд, которые я указал выше, то я не знаю, для чего не скриптовать вообще.

Последнее предложение есть лирика, а поэтому каждый волен работать так, как ему удобно.

И последнее в этой части: горячая клавиша F5 — список ключей. Просто нужно ознакомиться, тем более, всё на понятном языке.

Создание собственного шаблона документа

Структура шаблона

Шаблон — это совокупность настроек, общие для данной серии документов. Да. Звучит как-то официально. Слишком общее определение. Давайте наполним это определение конкретикой.

Настройки шаблона документа — это всякого рода нумерация страниц, форматирование, например, добавление колонтитулов, абзацы с отступами и прочие излишества и радости редактуры. Но не следует увлекаться этим, так как может уже появиться не шаблон, а полноценный документ. Ну, а самые общие параметры, это размер бумаги, а точнее, количество строк и символов в строке.

Пример создания шаблона

Какой нам нужен шаблон? Допустим, нам нужно 28 строчек и 32 символа в строке. Еще нам нужно, чтобы нумерация страниц начиналась с единицы и располагалась эта арабская циферка именно в правом верхнем углу. А еще мы хотим, чтобы нумерация страниц печаталась только на нечётных страницах. Нынче бумага дорогая, и каждую верхнюю строчку на чётной странице можно использовать под полезный текст. А еще мы хотим расположить некий заголовок, который будет повторяться только на нечётной странице и указывать на то, какую книгу мы всё же читаем, а то вдруг, читая страницу под номером 50 мы забудем, что жеэто за книга.

Так как у меня нет брайлевского принтера, то при настройке этого ценнейшего оборудования я выбрал вариант Generic в меню Общие -> пункт Настройка принтера брайля... Как настраивать оборудование,я здесь рассказывать не стану, вы же специалисты, не правда ли? Я не специалист, и у меня его нет, а поэтому, просто возьмём Generic.

В этом меню как раз и задаются настройки бумаги и прочая информация о строках и символах. Не так важно, что вы выбрали в меню Общие -> Настройки принтера брайля..., важно, какие настройки будут касаться документа.

Теперь создадим наш первый шаблон. Начнём с выбора шаблона, на основе которого мы будем делать наш. Конечно же, на основе русского. Поехали!

  1. запускаем наш брайлевский транслятор. Нажимаем горячку Control + N и в качестве основного шаблона выбираем «Russian — basic».
  2. Выбираем меню Документ -> пункт Настройка брайлевского принтера... Или же жмём горячку Control + F11. Открывается диалоговое окошко, в котором практически всё так же, как и в общих настройках брайлевского принтера. Но в списке уже установлен наш брайлевский принтер-пустышкаGeneric.
  3. Табулируем и попадаем на комбинированный список «Требуемое форматирование брайлевского документа форма:». Здесь установлен формат бумаги «A4 (210 X 297mm)». Ппротабулировав далее, читаем, сколько там «Знаков в строке:» и «Строк на странице». Кстати, можно нажать указанные горячки, но тут лучше табулировать. Знаков в строке для текущего формата бумаги — 30, а строк на странице — 28. Количество строк нас должно устраивать, а знаков маловато. Мы хотим 32. казалось бы, мы находимся на поле редактирования, а стало быть, можно ввести свои произвольные цифры. Ан нет! Так нельзя делать!
  4. Нужно выбрать бумагу. выберем подходящий из комбинированного списка.
  5. Перебрав и просмотрев все варианты, останавливаем свой выбор на «Узкий лист длиной 12 дюймов». Как раз требуемые значения знаков и строк. Пропускаем все другие элементы управления, нам они не нужны, и подтверждаем изменения нажатием волшебной кнопки. Обана! Выходит еще одно окно, в котором нас честно предупреждают, что форматирование документа изменено. Но наш документ ведь пуст! Мы создаем шаблон!
  6. Теперь нам надо выбрать нумерацию страниц и место её расположения, в смысле, нумерации. Выбираем меню Документ -> пункт Нумерация страниц ... Проходимся по всем значениям и видим, что они выставлены правильно. Ведь мы создаём наш шаблон на основе русского шаблона, который подготовлен создателями этого приложения. Только в поле редактирования «Начать нумерацию с номера:» вписываем цифру один. И подтверждаем изменения.
  7. Добавим небольшой колонтитул, то бишь, надпись левее нумерации страниц. Выбираем меню Вёрстка -> пункт Верхний колонтитул...
  8. В поле редактирования «Текст верхнего колонтитула:» вписываем текст. Мы черкнём что-то, типа, «dbt» без кавычек, разумеется.
  9. В группе радиокнопок «Помещать верхний колонтитул:» выбираем кнопку «На нечётных страницах» и подтверждаем проделанные изменения.
  10. Переключим режим просмотра ключей и оценим результаты нашей деятельности. Что мы получили? А получили мы следующее:
    [svrhp1]
    [tls]dbt[tle]

    [svrhp1] Этот ключ предписывает установить верхний колонтитул на нечётных сторонах страницы.
    [tls]текст[tle] Два ключа — начало и конец колонтитула. И между ними текст.
  11. Создаём наш шаблон на основе этих параметров. Выбираем меню Документ -> пункт Создать шаблон... Вписываем желаемое название шаблона и, не задевая других элементов, доходим до волшебной кнопки и подтверждаем изменения. Выходит новое окошко, в котором транслятор спрашивает, хотим ли мы сохранить текст и теги в шаблоне, мы соглашаемся.
  12. Проверяем наш шаблон. закрываем приложение, ничего не сохраняя. открываем приложение заново и выбираем наш созданный шаблон из списка шаблонов. Проверяем его.

Вместо заключения

В статье были рассмотрены базовые понятия и основные приёмы работы с программой duxbury. остались не затронутыми такие темы, как создание таблиц, содержания, вставка иллюстраций и нотной записи, импорт и экспорт файлов. За рамками этой статьи осталась и Математика . При желании и необходимости с этими вопросами можно разобраться самостоятельно.



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2022