Работа на персональном компьютере в среде Windows без применения мышки и без помощи глаз

(Лекционный курс)
Дата публикации:2005
Поделиться в Twitter Поделиться в F******k Поделиться в VKontakte Поделиться в Telegram

Редактор текстов Microsoft Word

Урок 1: Ввод и редактирование текста. Открытие и сохранение файла

Обзор урока.

Word можно запустить из Главного меню, с Рабочего стола, по комбинации горячих клавиш или открыв в любой папке файл с расширением "DOC" или с другим расширением при помощи команды "Открыть с помощью".

В меню "Вид" можно выбирать разные способы представления текста в окне Word и разные масштабы отображения символов.

Джоз может озвучивать набираемый с клавиатуры текст по буквам, по словам или вообще не озвучивать. Режим озвучивания набираемого текста регулируется комбинацией Insert+2".

Для перемещения курсора по тексту применяются все курсорные клавиши, как самостоятельно, так и в комбинации с клавишей "Control". Посимвольное, пословное, построчное, по предложениям и перемещение курсора по абзацам сопровождается чтением текста Джозом. Есть также возможность читать текущий символ, текущее слово, текущую строку, часть строки слева или справа от курсора, текущее предложение, текущий абзац и весь текст непрерывно от позиции курсора и до конца текста.

По командам из меню "Файл" можно открывать уже существующие файлы или открывать чистые окна Word для создания новых документов. Переход между открытыми окнами Word осуществляется по "Control+F6" и "Control+Shift+F6". Закрывается отдельное окно Word по "Control+F4". В Word 2000 окна Word ведут себя как полностью самостоятельные программы.

Выделение текста осуществляется теми же клавишами, что и перемещение курсора. Только добавляется клавиша "Shift". Можно выделять символ, слово, строку, часть строки слева или справа от курсора, абзац, экран текста, весь текст, часть текста от начала документа до курсора или от курсора до конца документа. Выделяемый текст должен быть непрерывным, во время всего выделения клавиша "Shift" должна быть зажата. Любой нажатый без "Shift" символ заменит собой весь выделенный текст. Нажатие без использования "Shift" любой курсорной клавиши отменит выделение текста.

Копирование, вырезание, вставка выделенного текста осуществляется через буфер обмена по командам из меню "Правка". Либо через контекстное меню, либо при помощи нажатия комбинаций горячих клавиш. Результаты редактирования текста можно отменить, воспользовавшись откатом. Команда отката стоит первой в меню "Правка". Можно делать несколько откатов подряд.

Если мы открываем уже существующий файл, а затем сохраняем его на диске командой "Сохранить", то файл будет сохранён поверх существующего файла, с тем же именем, в той же папке и в той же кодировке. При сохранении вновь созданного файла будет вызван стандартный диалог сохранения файла, где можно задать файлу имя, адрес на диске и кодировку. Тип кодировки определяет расширение файла. По умолчанию Word предложит папку Мои документы, кодировку "Документ Word" с расширением DOC, а в качестве имени файла - первые 20 символов из первой строки текста. Команда Сохранить как всегда вызывает стандартный диалог сохранения текста при сохранении как нового, так и уже существующего файла.

При сохранении файла в кодировках, в названии которых присутствуют слова "с разбиением на строки", каждая видимая на экране строка сохраняется как абзац. Это даёт возможность легко работать с таким текстом программой Блокнот, ДОСовскими редакторами и чтецами текстов, но очень сильно затрудняет в дальнейшем форматирование текста средствами Word.

Чтобы иметь возможность открывать с помощью Word ДОСовские файлы с расширением "txt", необходимо в настройке параметров Word на вкладке "Общие" установить флажок "Подтверждать преобразование при открытии". Тогда при открытии всех файлов с расширениями, отличными от DOC, можно будет выбирать тип файла и различить типы "Только текст" и "Текст ДОС".

Задания к уроку

1. Найти и запустить Microsoft Word из Главного меню, пункт Программы.

2. Выйти на Рабочий Стол, найти там ярлык, указывающий на Word и открыть его.

3. Закрепить за ярлыком программы Word на Рабочем Столе или в Главном меню комбинацию горячих клавиш "Control+Alt+W". Испытать, как она работает.

4. Запустить из Главного меню диалог поиска файлов и папок. Задать в качестве искомого имени маску документов Word ("*.DOC").Открывать найденные файлы. Убедиться, что они открываются программой Word.

5. Открыть папку "Мои документы" через Главное меню, подменю "Документы". Найти и открыть файл "Блокнот1.txt" редактором Word, используя команду "Открыть с помощью".

6. Изучите меню "Вид" окна Word. Отмените вывод на экран линейки, чтобы Джоз не произносил лишних слов при запуске Word. Установите масштаб 75%, чтобы строки текста полностью были видны на экране и полностью озвучивались Джозом.

7. .В чистом окне Word наберите строчку "Абзац 1", нажмите "Shift+Enter".

Дальше наберите "предложение 1." и нажмите "Shift+Enter".

Наберите дальше "Абзац 1, предложение 2." и нажмите "Enter".

Наберите дальше "Абзац 2, предложение 1" и нажмите "Enter".

Наберите дальше "Абзац 3, предложение 1".

Прочитайте последнюю строчку по Insert+Стрелка Вверх" Перейдите "Стрелкой Вверх" на верхнюю строчку, прочитайте её по Insert+Стрелка Вверх". Дойдите "Стрелкой Вверх" до первой строки.

Пройдите "Стрелкой Вниз" до конца текста.

Вернитесь в начало текста по "Control+Home". Читайте первую строчку текста посимвольно горизонтальными стрелками и "Серой пятёркой", а также быстрым двойным нажатием "Серой пятёрки".

Затем прочитайте весь текст по словам при помощи "Control+Стрелка Вправо". Некоторые слова перечитывайте одинарным и двойным нажатием Insert+Серая пятёрка". Вернитесь назад по "Control+Стрелка Влево", перечитывая по пути некоторые слова. Читайте также текст как слева, так и справа от курсора, по Insert+ Home"и Insert+PageUp".

Перейдите в конец текста по "Control+End". Прочитайте весь текст назад и вперёд по предложениям при помощи "Alt+Стрелка Вверх" и "Alt+Стрелка Вниз", а также по абзацам при помощи "Control+Стрелка Вверх" и "Control+Стрелка Вниз". Читайте текущее предложение и текущий абзац по "Alt+Серая пятёрка" и "Control+Серая пятёрка". Ощутите разницу между предложением и абзацем.

Перейдите в начало текста по "Control+Home" и прочитайте весь текст по команде Insert+Стрелка Вниз".

Выдайте команду "Сохранить" из меню "Файл". После открытия диалога сохранения файла наберите с клавиатуры "Word1 абзацы и предложения" и нажмите "Enter". Файл сохранится в папке "Мои документы" под именем "Word1 абзацы и предложения.doc". Переходя по "Control+F6" в другие окна Word, закройте все пустые окна командой "Control+F4".

8. 7.Выделите первое слово в тексте посимвольно при помощи "Shift+Стрелка Вправо". Проверьте выделение по "Shift+Insert+Стрелка Вниз". Скопируйте выделенное слово в буфер обмена по команде "Копировать" из меню "Правка". Откройте новое окно Word по команде "Создать" из меню "Файл" и вставьте туда текст из буфера обмена по команде "Вставить" из меню "Правка". Проверьте, что получилось, и вернитесь в окно с текстом по "Control+F6".

Выделите 2 слова из второй строки текста по "Shift+Control+Стрелка Вправо". Скопируйте в буфер обмена. Перейдите в открытое ранее окно по "Control+F6". Переведите курсор в конец текста по "Control+End". Выделите новую строку, нажав "Enter", и вставьте текст из буфера обмена командой "Вставить" из меню "Правка". Проверьте результат и вернитесь в окно "Word1 абзацы и предложения".

Выделите третью строчку, найдя её стрелками, став в начало строки по "Home" и выделив текст по "Shift+Стрелка вниз". Скопируйте выделенную строку в буфер обмена, используя контекстное меню. Перейдите в конец документа по "Control+End". Вставьте текст из буфера обмена, используя контекстное меню. Тут же повторите вставку текста. С помощью вертикальных стрелок проверьте результат.

9. Выделите и вырежьте первое слово в первой строке текста. Переместите клавишей "End" курсор в конец строки и вставьте туда слово из буфера. Прочитайте строку. Восстановите всё, 2 раза воспользовавшись откатом (первая команда в меню "Правка").

С помощью выделения, вырезания и вставки поменяйте местами первую и вторую строки текста. Затем верните всё назад, 2 раза воспользовавшись откатом.

Выделите 2 слова из середины третьей строки, удалите их, нажав "Delete". Убедитесь, что удаление произошло, прочитав строку по Insert+Стрелка Вверх". Отмените удаление, воспользовавшись откатом. То же самое повторите для всей третьей строки.

10. 8.Найдите и выдайте команду "Сохранить как". В раскрывшемся диалоге сохранения файла отредактируйте имя "Word1 абзацы и предложения" так, чтобы получилось "Word1". Используйте клавиши "End" и "BackSpace". Перейдите Табуляцией в поле "Тип файла" и выберите там тип "Только текст", используя стрелки или нажимая букву "т". Нажмите клавишу "Сохранить" для сохранения файла в папку "Мои документы" под именем "Word1.txt".

Не закрывая Word, войдите в "Мои документы" и проверьте наличие файлов "Word1 абзацы и предложения.doc" и "Word1.txt". Вернитесь при помощи "Alt+Tab" в Word.

11. 9.Сохраните тот же файл, поменяв имя на "Word1 ДОС", а тип файла на "Текст ДОС с разбиением на строки". Перейдите в окно проводника, обновите его содержимое по "F5" и убедитесь в появлении нового файла "Word1 ДОС.txt". Вернитесь в окно Word и закройте его по "Control+F4".

12. Находясь в Word, запустите пункт "Параметры" из меню "Сервис". Найдите вкладку "Общие", протабулируйте до флажка "Подтверждать преобразование при открытии". Если флажок не установлен, установите его Пробелом. Нажмите "Enter" для сохранения результатов.

13. Найдите в папке "Мои документы" файлы "Word1.txt" и "Word1 ДОС.txt". Откройте их по очереди редактором Word, воспользовавшись командой "Открыть с помощью". Выбирайте нужную для каждого файла кодировку из предложенного редактором Word списка форматов файлов.

14. Запустите Word или создайте новое окно. Наберите строку текста из нескольких слов. Используя перемещение по словам ("Control+Стрелка Вправо", "Control+Стрелка Влево"), разбейте эту строчку на несколько строчек нажатием "Enter". Затем склейте все строки опять в одну строку, становясь каждый раз в начало нижней строки и нажимая "BackSpace". Повторите всё это, пользуясь для разбиения строки комбинацией "Shift+Enter". Найдите и объясните разницу, применяя чтение разбитых строк по абзацам.

Список горячих клавиш к уроку

Горячие клавиши Word

клавиши-стрелки - перемещение по тексту

Home - переместиться в начало строки

End - переместиться к концу строки

Pageup или Pagedown - прокрутить текст на один экран вверх или вниз

Control+стрелка_вниз или Control+стрелка_вверх - переместиться на абзац вперёд или назад

Control+Home - переместиться к началу текста

Control+End - переместиться в конец текста

Control+PageUp - предыдущая страница

Control+PageDown - следующая страница

Control+Z - откат или отмена предыдущего действия, например, удаления

Control+F4 - закрыть текущее окно, активным станет текст из следующего окна

Control+F6 - переход к следующему окну Word

Control+Shift+F6 - переход к предыдущему окну Word

Delete - удалить символ справа

BackSpace - удалить символ слева

Control+Delete - удалить слово справа

Control+BackSpace - удалить слово слева

Alt+Control+I - переключение режимов вставка/замена

Enter - разрыв строки с созданием абзаца

Shift+Enter - разрыв строки без создания абзаца

Shift+горизонтальная стрелка - выделить символ

Shift+Вертикальная Стрелка - выделить строку

Shift+Control+стрелка_влево или Shift+Control+стрелка_вправо - выделить одно слово

Shift+Home - выделить от курсора до начала строки

Shift+End - выделить от курсора до конца строки

Shift+Pageup или Shift+Pagedown - выделить экран текста вниз или вверх

Shift+Control+Home - выделить до начала файла

Shift+Control+End - выделить до конца файла

F8 - начало выделения блока (повторное нажатие выделяет текущее слово, предложение, абзац или весь текст)

Escape дважды - выход из режима выделения блока

Горячие клавиши JAWS

Insert+Delete - назвать номер строки и номер позиции в строке

Control+Insert+V - сказать версию Word

5 на цифровой клавиатуре - назвать текущий символ в тексте либо назвать горячую (подчёркнутую или первую) букву пункта меню или кнопки, которую затем можно использовать для ускоренного вызова данного пункта меню или нажатия данной клавиши при помощи Alt . Если нажать быстро дважды, JAWS назовёт слово, начинающееся с этой буквы

Insert+5 (на цифровой клавиатуре) - Озвучивается слово в позиции активного курсора. Если эту комбинацию клавиш быстро нажать дважды, слово будет озвучено посимвольно.

Insert+стрелка_влево - озвучивается предыдущее слово в отношении активного курсора

Insert+стрелка_вправо - озвучивается следующее от активного курсора слово

Insert+стрелка_вверх - озвучивается текущая строка или пункт меню

Insert+стрелка_вниз - Если активным является PC курсор, читается весь документ. Если является активным Jaws курсор, читается только текст в окне

Insert+Home - прочитать от начала строки до текущего курсора

Insert+Pageup - прочитать от текущего курсора до конца строки

Insert+Shift+стрелка_вниз - прочитать выделенный текст

Insert+2 - эхо клавиатуры. Эхо клавиатуры циклически переключается через четыре возможные значения: слова, символы, слова и символы и выключено.

Insert+3 - пропустить следующую комбинацию к приложению без обработки её Джозом. Например, комбинации, включающие Insert, иначе просто не могут попасть к приложению, так как перехватываются Джозом

ctrl+insert+nam pad slash - выделение текста в режиме JAWS-курсора

Вернуться к оглавлению урока



Распространение материалов сайта означает, что распространитель принял условия лицензионного соглашения.
Идея и реализация: © Владимир Довыденков и Анатолий Камынин,  2004-2022